Project

General

Profile

Bug #1941

Gb: implement MM state ready, idle, standby including T3314

Added by lynxis over 2 years ago. Updated 30 days ago.

Status:
Feedback
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/04/2017
Due date:
% Done:

90%

Spec Reference:
24.008

Description

MM state reflects the knowledge of the MS' location in the network.
Implement the state and add the hooks so the states are tracked.

READY: exact cell is known
STANDBY: RA known
IDLE: unknown location

On receivement of a DL PDU for the MS, the SGSN has to:
READY: send DL PDU to PCU (already done)
STANDBY: page MS in RA (seperate ticket)
IDLE: deactivate pdp context? (check spec)

T3314 defines the time while the MS is in READY state. When T3314 expires the MM state is set to STANDBY.

History

#1 Updated by laforge about 2 years ago

  • Assignee changed from lynxis to sysmocom

#2 Updated by laforge 6 months ago

  • Assignee changed from sysmocom to lynxis

#3 Updated by pespin 2 months ago

  • Assignee changed from lynxis to pespin

#4 Updated by pespin about 2 months ago

  • Status changed from New to Resolved
  • % Done changed from 50 to 100

Patch merged, closing the ticket.

#5 Updated by pespin about 1 month ago

  • Status changed from Resolved to In Progress
  • % Done changed from 100 to 70

It was spotted that with patch merged READY->STANBY is working fine, but STANDBY->READY is still not properly implemented. That's because gsm0408_gprs_notify_pdu_gb() is called only on the CONTROL code path, but should be called also when a DATA/USER packet is received.

In any case, it's not a regression because we are currently not checking for MM_STATE==READY in any place when trying to page. That needs to be introduced too.

#6 Updated by pespin 30 days ago

  • Status changed from In Progress to Feedback
  • % Done changed from 70 to 90

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)