Project

General

Profile

Actions

Bug #6275

closed

ttcn3-pcu-test-sns regressions

Added by fixeria 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
11/26/2023
Due date:
% Done:

100%

Spec Reference:
Tags:

Description

ttcn3-pcu-test-sns looks unhealthy since recently:

https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-pcu-test-sns/
https://jenkins.osmocom.org/jenkins/view/TTCN3-centos/job/TTCN3-centos-pcu-test-sns/

Note that the -latest is not affected. Also note a core file in the artifacts.

The logging suggests there is a version mismatch?

PCU interface version number of BTS/BSC (11) is different (12).
Please use a BTS/BSC with a compatble interface!
0: stopped pid 8 with status 255
Actions #1

Updated by dexter 3 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

I think the problem is just due to the wrong PCUIF version number. I have changed it now:

https://gerrit.osmocom.org/c/docker-playground/+/35136 ttcn3-pcu-test/sns: fix PCUIF version number

Actions #2

Updated by dexter 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

The problem was indeed a misconfiguration of the PCUIF version number. This is now fixed and ttcn3-pcu-test-sns looks normal again. We can close this ticket now.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)