Project

General

Profile

Actions

Bug #6267

closed

ttcn3 open5gs testsuites started failing

Added by osmith 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
11/21/2023
Due date:
% Done:

100%

Spec Reference:

Description

Since Nov 20, the open5gs testsuites are completely failing.

A quick glance at ttcn3-pgw-test logs show that nrf and upf fail to start up, both with:

  11/21 07:39:25.971: [app] INFO: Configuration: '/data/open5gs-nrf.yaml' (../lib/app/ogs-init.c:130)
  11/21 07:39:25.971: [core] FATAL: epoll_init: Assertion `context->epfd >= 0' failed. (../lib/core/ogs-epoll.c:77)
  11/21 07:39:25.971: [core] FATAL: backtrace() returned 8 addresses (../lib/core/ogs-abort.c:37)

Looks like the only big change that was merged recently is this:
https://github.com/open5gs/open5gs/pull/2739

Looking more into it.

Actions #1

Updated by osmith 3 months ago

  • % Done changed from 0 to 30

I have set up a local environment to build open5gs and run the ttcn3 configs, and reproduced the error.

The config format has changed, we will need to adjust our configs again as in the new format, with that it works again.
https://github.com/open5gs/open5gs/blob/main/configs/open5gs/upf.yaml.in

The format is quite different from before, so we will need to adjust the docker-playground scripts to use an old config for testing -latest and the new config for testing master/main.

Actions #2

Updated by osmith 3 months ago

  • % Done changed from 30 to 60

The config format has changed, we will need to adjust our configs again as in the new format, with that it works again.

done, docker-playground.git branch osmith/wip

Actions #3

Updated by osmith 3 months ago

  • % Done changed from 60 to 90

we will need to adjust the docker-playground scripts to use an old config for testing -latest and the new config for testing master/main.

done as well.

https://gerrit.osmocom.org/q/topic:open5gs-configs-update

Actions #4

Updated by osmith 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)