Project

General

Profile

Actions

Feature #6187

closed

Update titan.core to 9.0.0 in osmocom repositories

Added by pespin 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
09/21/2023
Due date:
% Done:

100%

Spec Reference:

Description

AFAIK we now ship titan 8.3.0, bit 9.0.0 is already available upstream with several bug fixes.

We may want to update it to 9.0.0.


Related issues

Related to Core testing infrastructure - Feature #5323: Add docker image containing titan.core masterNew11/22/2021

Actions
Actions #1

Updated by pespin 5 months ago

  • Related to Feature #5323: Add docker image containing titan.core master added
Actions #2

Updated by osmith 5 months ago

Actions #3

Updated by pespin 5 months ago

I'm fine with that. Let's see if fixeria or laforge have any concern.
I didn't look at the release notes nor commit history in detail. It may make sense to have a look and see if there are fixes for new regressions after 9.0.0.

Actions #4

Updated by laforge 5 months ago

I don't have any specific remarks. In general it is good to follow upstream unless there are known significant regressions affecting our test suites

Actions #5

Updated by fixeria 5 months ago

pespin wrote in #note-3:

I'm fine with that. Let's see if fixeria or laforge have any concern.
I didn't look at the release notes nor commit history in detail. It may make sense to have a look and see if there are fixes for new regressions after 9.0.0.

Even though the '9.0.0' is a major release, it's not that far away from the '8.3.0' (see git log --oneline 9.0.0 ^8.3.0): only 44 commits and mostly ASN.1 related patches (adding PER support, incomplete yet). I have the 9.0.0 installed since I migrated to a new laptop and so far was mostly running ttcn3-bts-test. No regressions observed. I am fine with upgrading the testsuite infra to use it, no concerns. But I don't see any major benefits, so maybe reduce to Low prio?

After writing the above part, I took a closer look and found out that several of your bug reports have been fixed in this release:

https://gitlab.eclipse.org/eclipse/titan/titan.core/-/issues/636
https://gitlab.eclipse.org/eclipse/titan/titan.core/-/issues/690

Actions #6

Updated by osmith 5 months ago

  • Status changed from New to Resolved
  • Assignee set to osmith
  • % Done changed from 0 to 100

Upgraded it to 9.0.0:
https://obs.osmocom.org/package/show/osmocom:latest/eclipse-titan

It will take a bit until it gets used in the jenkins jobs (binary package needs to build first etc.).

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)