Project

General

Profile

Actions

Support #5663

closed

No Package 'libosmousb' found

Added by jelson_simEng 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
host software
Target version:
Start date:
08/26/2022
Due date:
% Done:

100%

Spec Reference:

Description

Hello All,

Thanks for the help in advance.
I am trying to build the simtrace2 code but i am getting an error after running the ./configure command, hence, the make command wont even run because the Makefile seems to not be created, can anyone help me understand this error?

The main error message is :
No Package 'libosmousb' found

Note: I tried to do the procedure with the binary packages but that wont work for me, it will always say package simtrace2 not found.

I am running the program on a Ubuntu 22.04 LTS VM on Virtual Box, with a Windows 10 Host.
Attached i will leave the commands logs.

Thanks in advance


Files

autoreconf.log autoreconf.log 882 Bytes jelson_simEng, 08/26/2022 09:08 AM
configure.log configure.log 4.33 KB jelson_simEng, 08/26/2022 09:08 AM
Actions #1

Updated by laforge 4 months ago

  • Tracker changed from Bug to Support
  • Status changed from New to Feedback
  • Assignee set to jelson_simEng

This is not a bug, reclassifying. It is the normal process of how building any software with GNU autotools works for the last 20+ years. the configure script checks your OS/environment for the availability of the (development) package of all its dependencies, and if they don't exist, it exits.

You will need to install libosmousb (part of libosmocore.git) first.

But honestly, if you are not familiar with building open source software with autotools, you really should use the binary packages. Please post the exact commands and output messages you're seeing for 'apt update' and 'apt install simtrace2-utils'. We do build the simtrace2 package and all of its dependencies every night for Ubuntu 22.04. My guess is that you somehow didn't install the proper apt configuration and/or key.

Proof of packages being built: https://obs.osmocom.org/package/binaries/osmocom:nightly/simtrace2/xUbuntu_22.04 - the results of which are at https://downloads.osmocom.org/packages/osmocom%3A/nightly/xUbuntu_22.04/amd64/

Actions #2

Updated by jelson_simEng 4 months ago

laforge wrote in #note-1:

This is not a bug, reclassifying. It is the normal process of how building any software with GNU autotools works for the last 20+ years. the configure script checks your OS/environment for the availability of the (development) package of all its dependencies, and if they don't exist, it exits.

You will need to install libosmousb (part of libosmocore.git) first.

But honestly, if you are not familiar with building open source software with autotools, you really should use the binary packages. Please post the exact commands and output messages you're seeing for 'apt update' and 'apt install simtrace2-utils'. We do build the simtrace2 package and all of its dependencies every night for Ubuntu 22.04. My guess is that you somehow didn't install the proper apt configuration and/or key.

Proof of packages being built: https://obs.osmocom.org/package/binaries/osmocom:nightly/simtrace2/xUbuntu_22.04 - the results of which are at https://downloads.osmocom.org/packages/osmocom%3A/nightly/xUbuntu_22.04/amd64/

###################################################################################################################################################

Hi laforge,

Indeed you are right, i am not very familiar with building open source software, i only tried this way because binary packages were not working.
But you have just showed me why binary packages were not working.
The final command 'sudo apt-get install simtrace2-utils' in the documentation appears as 'sudo apt-get install simtrace2', hence, the package name would not be recognized, i just noticed now in your comments that we should add the -utils and everything is working now.
I was reading this page for tutorials
https://osmocom.org/projects/simtrace2/wiki
And on this page it says only simtrace2.

Thank you so much for your help, i will close this one as resolved.

Thanks,
Jelson G.

Actions #3

Updated by jelson_simEng 3 months ago

Leaving here all the commands used for xUbuntu 22_04 LTS, using the latest builds:

$ sudo su
# wget https://downloads.osmocom.org/packages/osmocom:/latest/Debian_11/Release.key
# sha256sum Release.key
1d0e8f6e67b84b6262767596a183d585c9a26cba793bbc862eb16fa3762db4b7  Release.key
# mv Release.key /etc/apt/trusted.gpg.d/osmocom-latest.asc
# echo "deb https://downloads.osmocom.org/packages/osmocom:/latest/Debian_11/ ./" > /etc/apt/sources.list.d/osmocom-latest.list
# apt-get update
# exit

$ sudo apt-get install simtrace2-utils

And then, to run the sniffer, or other command i just did

$ simtrace2-sniff, or simtrace2-list etc.

Note - if you did not add the users in the plugdev group you may have to sudo the above commands, like sudo simtrace2-sniff.

Hope it helps you.

Thanks,
Jelson G.

Actions #4

Updated by laforge 3 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

jelson_simEng wrote in #note-2:

The final command 'sudo apt-get install simtrace2-utils' in the documentation appears as 'sudo apt-get install simtrace2', hence, the package name would not be recognized, i just noticed now in your comments that we should add the -utils and everything is working now.
I was reading this page for tutorials
https://osmocom.org/projects/simtrace2/wiki
And on this page it says only simtrace2.

Thanks for reporting. The wiki has been updated. I also granted your user wiki editing privileges, in case you'd like to further improve it.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)