Project

General

Profile

Actions

Bug #5635

closed

ttcn3-bts-test: TC_rsl_ms_pwr_dyn_{ass_updown,max,up} and TC_ms_pwr_ctrl_{constant,pf_ewma} are failing

Added by fixeria 20 days ago. Updated 4 days ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
07/27/2022
Due date:
% Done:

100%

Spec Reference:
Tags:

Description

After the recent changes in osmocom-bb.git/trxcon, we started to see some new regressions. Some of them caused by the problem explained in #3761:

  • Sending L1 SACCH header = { 0x00, 0x00 } in cached SACCH PDUs.
    • You'll see "FIXME: no direct access to trx->{tx_power,ta}" during compilation.
    • Makes TC_rsl_ms_pwr_dyn_{ass_updown,max} and TC_ms_pwr_ctrl_{constant,pf_ewma} fail.

The problem is likely in the testsuite itself, because generally we should not rely on cached measurements.


Checklist

  • BTS_Tests.TC_rsl_ms_pwr_dyn_up
  • BTS_Tests.TC_rsl_ms_pwr_dyn_ass_updown
  • BTS_Tests.TC_rsl_ms_pwr_dyn_max
  • BTS_Tests.TC_ms_pwr_ctrl_constant
  • BTS_Tests.TC_ms_pwr_ctrl_pf_ewma
Actions #1

Updated by fixeria 18 days ago

  • Status changed from New to In Progress
Actions #2

Updated by fixeria 16 days ago

  • % Done changed from 0 to 60

TC_rsl_ms_pwr_dyn_{ass_updown,max} fixed by:

https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/28868 BTS_Tests: increate Tguard to 30.0s for TC_rsl_ms_pwr_dyn_up [NEW]
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/28869 BTS_Tests: send SACCH blocks in TC_rsl_ms_pwr_dyn_{up,ass_updown}() [NEW]

TC_sacch_chan_act_ho_[a]sync fixed by:

https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/28833 BTS_Tests: tune back to CCCH/BCCH in TC_sacch_chan_act_ho_[a]sync [NEW]

Actions #3

Updated by fixeria 16 days ago

The situation with TC_ms_pwr_ctrl_{constant,pf_ewma} is a bit different. Unlike TC_rsl_ms_pwr_dyn_{ass_updown,max}, they do send MRs. The problem is that the first MR sent by trxcon is always a dummy MR, because we're scheduling bursts N TDMA frames in advance. Before the recent libl1sched refactoring trxcon used to patch MRs, so that the first MR would always indicate MS Power Level 0. Now it's indicating some hard-coded value which confuses the MS Power Loop in osmo-bts-trx.

Actions #4

Updated by fixeria 16 days ago

  • % Done changed from 60 to 80

TC_ms_pwr_ctrl_{constant,pf_ewma} fixed by:

https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/28875 library/GSM_RR_Types: make ts_SacchL1Header easier to use [NEW]
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/28876 BTS_Tests: populate SACCH cache in f_TC_ms_pwr_ctrl_{constant,pf_ewma} [NEW]
https://gerrit.osmocom.org/c/osmocom-bb/+/28874 trxcon: allow populating global SACCH cache via L1CTL [NEW]

Actions #5

Updated by fixeria 16 days ago

  • Checklist item BTS_Tests.TC_rsl_ms_pwr_dyn_up added
  • Checklist item BTS_Tests.TC_rsl_ms_pwr_dyn_ass_updown added
  • Checklist item BTS_Tests.TC_rsl_ms_pwr_dyn_max added
  • Checklist item BTS_Tests.TC_ms_pwr_ctrl_constant added
  • Checklist item BTS_Tests.TC_ms_pwr_ctrl_pf_ewma added
  • Subject changed from ttcn3-bts-test: TC_rsl_ms_pwr_dyn_{ass_updown,max} and TC_ms_pwr_ctrl_{constant,pf_ewma} are failing to ttcn3-bts-test: TC_rsl_ms_pwr_dyn_{ass_updown,max,up} and TC_ms_pwr_ctrl_{constant,pf_ewma} are failing
  • Status changed from In Progress to Feedback
  • % Done changed from 80 to 100
Actions #6

Updated by fixeria 5 days ago

  • Status changed from Feedback to In Progress
  • % Done changed from 100 to 60

All patches have been merged, but it seems we're not done yet:

  • TC_ms_pwr_ctrl_{constant,pf_ewma} are fixed and green now,
  • TC_rsl_ms_pwr_dyn_{ass_updown,max,up} are still failing.
Actions #7

Updated by fixeria 5 days ago

  • Status changed from In Progress to Feedback
  • % Done changed from 60 to 100

I broke initially correct logic of https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/28869 while addressing code review comments.

https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/29022 BTS_Tests: use f_send_meas_rep() in f_TC_ms_pwr_ctrl_{constant,pf_ewma} [NEW]
https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/29023 BTS_Tests: fix TC_rsl_ms_pwr_dyn_{up,ass_down,max}: reply received SACCH L1H [NEW]

Actions #8

Updated by fixeria 4 days ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)