Project

General

Profile

Actions

Bug #5542

closed

Move hub to datacenter colocation

Added by laforge 7 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/21/2022
Due date:
09/19/2022
% Done:

90%


Description

Now that things are more stable, we want to move the hub to a colocation in a data center.

Right now, I'm getting the funding / sponsoring for the colocation sorted out, I had previously received positive signals from old contacts at noris.net.

Let's collect a plan at Colocated_Hub


Files

gps_antenne_rohr.jpg View gps_antenne_rohr.jpg 1.53 MB laforge, 07/22/2022 08:20 AM

Checklist

  • figure out sponsored colocation
  • acquire a related machine (server)
  • detailed plan of physical setup
  • C*NET ENUM DNS update

Subtasks 4 (0 open4 closed)

Feature #5623: select, purchase and set-up server for octoi hub colocationResolvedlaforge07/22/2022

Actions
Feature #5624: design / prototyping / testing of icE1usb RS485/422 daughterboard Resolvedlaforge07/22/2022

Actions
Feature #5626: mechanical + electrical setup for GPS receiver at co-locationResolvedlaforge07/22/2022

Actions
Feature #5627: mechanical assembly of icE1usb, 12V PSU, RS485 into 1U enclosureResolvedlaforge07/22/2022

Actions

Related issues

Related to OCTOI - Osmocom Community TDM over IP - Feature #5667: Test different PM3 for ZModem throughputResolvedlaforge08/29/2022

Actions
Related to OCTOI - Osmocom Community TDM over IP - Support #5690: migrate OCTOI users over to co-locate divf.retronetworking.orgResolvedlaforge09/23/2022

Actions
Related to OCTOI - Osmocom Community TDM over IP - Feature #5625: icE1usb gateware/firmware support for external GPS receiverResolvedtnt07/22/2022

Actions
Actions #1

Updated by laforge 4 months ago

  • Checklist item figure out sponsored colocation set to Done
Actions #2

Updated by laforge 4 months ago

  • Status changed from New to Stalled
  • % Done changed from 0 to 10

still waiting for clarification on the GPS situation (RS485-PPS in one data centre or RF-over-fiber in the other). Sent another ping today.

Actions #3

Updated by laforge 4 months ago

  • Status changed from Stalled to In Progress

laforge wrote in #note-2:

still waiting for clarification on the GPS situation (RS485-PPS in one data centre or RF-over-fiber in the other). Sent another ping today.

So, today I finally received confirmation: We will bein the data centre where RS-485 over CAT-5 is used for the clock between rack and roof.

This means:
  • On the roof
    • GPS antenna
    • Ericsson GPS_02 (on DIN-Rail)
    • RS-485 overvoltage protector[s] (on DIN-Rail)
  • In the rack
    • icE1usb
    • phantom voltage power supply (12V)
    • RS485 converter for 1PPS + NMEA

TBD: get some idea about the cable length and figure out if the 12V phantom supply really can run over that kind of distance

tnt - are you still willing / able to work on some kind of icE1usb internal RS485 board? Given that we need to feed the 12V phantom voltage into the same CAT5, having an external board with something like a current limit / fuse and a DC barrel connector for an external PSU would probably make equal sense.

Given that all of this has to go into a rack, it might even make sense to mount the icE1usb, RS485 bits 12V PSU etc. all in a 1U enclosure. At that point it becomes irrelevant if the RS485 converters are inside the typical icE1usb enclosure or not.

Actions #5

Updated by tnt 4 months ago

We need "some" internal board anyway because the GPIO connector links to ... nothing.
It relies on a internal board to link some RJ45 pins to some of the available signals.
So I figured we might as well put the transceivers on there since that could then be re-used for other use-cases (or adapted for).

Actions #6

Updated by laforge 4 months ago

tnt wrote in #note-5:

We need "some" internal board anyway because the GPIO connector links to ... nothing.
It relies on a internal board to link some RJ45 pins to some of the available signals.

yes, that could have simply been a bridge

So I figured we might as well put the transceivers on there since that could then be re-used for other use-cases (or adapted for).

indeed. that other use case would probably need the inverse direction? so you'd at least need one direction-switchable transceiver and two fixed ones?

So I'll leave the RS4xx interface in your hands and assume we will have 2xRx and 1xTx pair on that spare RJ45 of the icE1usb.

I'll meanwhile focus on the following bits:
  • mechanical mounting of GPS antenna (picture of my setup at home attached; I still have some more of that model of GPS antenna MA-700G)
  • over voltage protection (LP-GTR-NFF on coaxial plus something like discussed above for RS4xx)
  • 12V power supply (phentom or not). The cable length is about 100m (!) no problem for the slow RS422/485, but that's about 20 ohms loop resistance for 12V. Need to test that.
Actions #7

Updated by laforge 4 months ago

I will be in Nuernberg (where the data centre is located) in the week of September 19, so my curren hope is to get everything procured, set up and tested before September 18, so I can then do the setup during that week.

Actions #8

Updated by laforge 4 months ago

  • Due date set to 09/19/2022
Actions #9

Updated by laforge 4 months ago

  • Checklist item acquire a related machine (server) set to Done
Actions #10

Updated by laforge 3 months ago

  • Related to Feature #5667: Test different PM3 for ZModem throughput added
Actions #11

Updated by laforge 3 months ago

  • Checklist item detailed plan of physical setup set to Done
Actions #12

Updated by laforge 2 months ago

  • % Done changed from 10 to 50

installation confirmed for Monday, September 19th from 9am CEST onwards.

Actions #13

Updated by laforge 2 months ago

  • % Done changed from 50 to 90
pending topics:
  • some icE1usb firmware cleanups (#5625)
  • migrating users over to the new hub (will create new issue)
Actions #14

Updated by laforge 2 months ago

  • Checklist item C*NET ENUM DNS update added

C*NET ENUM DNS update has been requested and confirmed, but actual DNS is still serving old data :(

Actions #15

Updated by laforge about 2 months ago

  • Checklist item C*NET ENUM DNS update set to Done
Actions #16

Updated by laforge about 2 months ago

C-Net ENUM update has been implemented:

1.2.3.4.0.3.9.4.std.ckts.info. 300 IN   NAPTR   100 10 "u" "E2U+IAX2" "!^\\+*(.*)$!iax2:/\\1!" .
Actions #17

Updated by laforge about 2 months ago

  • Status changed from In Progress to Resolved
Actions #18

Updated by laforge about 2 months ago

  • Related to Support #5690: migrate OCTOI users over to co-locate divf.retronetworking.org added
Actions #19

Updated by laforge about 2 months ago

  • Related to Feature #5625: icE1usb gateware/firmware support for external GPS receiver added
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)