Project

General

Profile

Actions

Bug #5426

closed

DAHDI not detecting icE1usb

Added by nickvsnetworking 10 months ago. Updated 10 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
DAHDI driver
Target version:
-
Start date:
01/29/2022
Due date:
% Done:

0%

Spec Reference:
Tags:

Description

Hi folks,

I've been struggling all afternoon to get the DAHDI drivers working with the icE1usb on Debian 11 or Ubuntu 20.04.

I've installed the Osmocom DAHDI-Linux and mainline DAHDI-tools with the below steps:

apt-get install linux-headers-`uname -r` git dfu-util make gcc autoconf libtool
git clone https://git.osmocom.org/dahdi-linux/
git clone https://github.com/asterisk/dahdi-tools

cd dahdi-linux
sudo make install

cd ../dahdi-tools
sudo autoreconf -i
./configure
sudo make install
sudo make install-config
dahdi_genconf modules (no output)
cat /etc/dahdi/modules (returns boilerplate config, comments only, no config.)
dahdi_genconf system (Returns "Empty configuration -- no spans")

Not 100% sure on if I should be running modprobe for the icE1usb but here's the output if I do:

modprobe icE1usb
modprobe: ERROR: could not insert 'icE1usb': Invalid argument

I get blinking green LEDs on both the E1 ports and solid red on the RGB LED.

But lsdahdi and dahdi_scan both return nothing, suggesting they're not able to detect it.

Osmoe1d is not running - but if I do run it, it does appear to see the icE1usb.

I thought maybe it was a firmware issue, so flashed what I think it the latest firmware, for the firmware I'm using is from the latest folder on the FTP icE1usb-fw.bin whith the creation timestamp 2022-Jan-29 03:01:07, and the Gateway Firmware from tnt - icE1usb-fw-0.2-6-gfdfabf9.bin with the creation timestamp 2020-Oct-09 11:46:48.

Both flashed OK.

lsusb sees it OK, after flashing, device ID suggests it's no longer in DFU mode.

Bus 001 Device 009: ID 1d50:6145 OpenMoko, Inc. icE1usb

I'm able to see the device in lsusb and syslog when I plug it in:

Jan 29 19:48:40 riis kernel: [  221.388979] usb 1-2.2: new full-speed USB device number 6 using uhci_hcd
Jan 29 19:48:40 riis kernel: [  221.780901] usb 1-2.2: New USB device found, idVendor=1d50, idProduct=6145, bcdDevice= 0.03
Jan 29 19:48:40 riis kernel: [  221.780904] usb 1-2.2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
Jan 29 19:48:40 riis kernel: [  221.780906] usb 1-2.2: Product: icE1usb
Jan 29 19:48:40 riis kernel: [  221.780907] usb 1-2.2: Manufacturer: osmocom
Jan 29 19:48:40 riis kernel: [  221.780908] usb 1-2.2: SerialNumber: dc697407e7783231
Jan 29 19:48:40 riis kernel: [  221.800655] cdc_acm 1-2.2:1.3: ttyACM0: USB ACM device
Jan 29 19:48:40 riis mtp-probe: checking bus 1, device 6: "/sys/devices/pci0000:00/0000:00:11.0/0000:02:00.0/usb1/1-2/1-2.2" 
Jan 29 19:48:40 riis mtp-probe: bus: 1, device: 6 was not an MTP device
Jan 29 19:48:40 riis mtp-probe: checking bus 1, device 6: "/sys/devices/pci0000:00/0000:00:11.0/0000:02:00.0/usb1/1-2/1-2.2" 
Jan 29 19:48:40 riis mtp-probe: bus: 1, device: 6 was not an MTP device

I can see DAHDI it installed in modprobe under /etc/modprobe.d/dahdi.conf,

root@riis:/home/nick/dahdi-tools# dmesg | grep -i dahdi
[    3.728777] dahdi: loading out-of-tree module taints kernel.
[    3.728934] dahdi: module verification failed: signature and/or required key missing - tainting kernel
[    3.730382] dahdi: Version: 2.11.1.0.20170917
[    3.735200] dahdi: Telephony Interface Registered on major 196
[    3.736211] dahdi_transcode: Loaded.
[  207.340816] dahdi_transcode: Unloaded.
[  207.350821] dahdi: Telephony Interface Unloaded
[  207.359780] dahdi: Version: 2.11.1.0.20170917
[  207.365783] dahdi: Telephony Interface Registered on major 196
root@riis:/home/nick/dahdi-tools# 

root@riis:/home/nick/dahdi-tools#  /etc/init.d/dahdi start
Loading DAHDI hardware modules:

using '/etc/dahdi/assigned-spans.conf'
Running dahdi_cfg: done.

root@riis:/home/nick/dahdi-linux# dmesg | grep 'dahdi\|usb'
[  163.902667] usb 1-2.2: new full-speed USB device number 5 using uhci_hcd
[  164.299747] usb 1-2.2: New USB device found, idVendor=1d50, idProduct=6145, bcdDevice= 0.03
[  164.299752] usb 1-2.2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[  164.299754] usb 1-2.2: Product: icE1usb
[  164.299756] usb 1-2.2: Manufacturer: osmocom
[  164.299757] usb 1-2.2: SerialNumber: dc697407e7783231
[  164.361118] usbcore: registered new interface driver cdc_acm
[  207.340816] dahdi_transcode: Unloaded.
[  207.350821] dahdi: Telephony Interface Unloaded
[  207.359780] dahdi: Version: 2.11.1.0.20170917
[  207.365783] dahdi: Telephony Interface Registered on major 196
[  216.459717] usb 1-2.2: USB disconnect, device number 5
[  221.388979] usb 1-2.2: new full-speed USB device number 6 using uhci_hcd
[  221.780901] usb 1-2.2: New USB device found, idVendor=1d50, idProduct=6145, bcdDevice= 0.03
[  221.780904] usb 1-2.2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[  221.780906] usb 1-2.2: Product: icE1usb
[  221.780907] usb 1-2.2: Manufacturer: osmocom
[  221.780908] usb 1-2.2: SerialNumber: dc697407e7783231

ps aux does not show a DADHI service, although I'm not 100% clear on if it is supposed to?

Any hints would be much appreciated!

Thanks!

Nick

Actions #1

Updated by laforge 10 months ago

Looks all good and should be working.

The error message to the modprobe is clearly the key. Can you check lsmod before and after? And see if diese has any more details at the time you try loading the module?

On January 29, 2022 10:28:59 AM GMT+01:00, nickvsnetworking <> wrote:

Issue #5426 has been reported by nickvsnetworking.

Actions #2

Updated by nickvsnetworking 10 months ago

Thanks Harald,

After banging my head on the table for a few more hours, I blew everything away again and started with the device unplugged, and I think that made the difference. After that modprobe worked without a hitch, and I can see the device now. I ran the build steps again just to make sure and no issues.

I've updated the Manual with build instructions for anyone else trying this in the future, apologies if I missed a step there (First contrib to Gerrit).

Thanks for your help!
Nick

Actions #3

Updated by laforge 10 months ago

  • Status changed from New to In Progress

nickvsnetworking wrote in #note-2:

After banging my head on the table for a few more hours, I blew everything away again and started with the device unplugged, and I think that made the difference. After that modprobe worked without a hitch, and I can see the device now. I ran the build steps again just to make sure and no issues.

strange. I will try to reproduce if that shows any problems.

In one of my setups I have the device plugged in permanently and [remotely] rebooted several times. This is also a situation where the device is plugged clearly before the driver is loaded.

I've updated the Manual with build instructions for anyone else trying this in the future, apologies if I missed a step there (First contrib to Gerrit).

Thanks, I added some comments there. Adding libnewt-dev is important IMHO, the other is optional.

Actions #4

Updated by laforge 10 months ago

  • Status changed from In Progress to Rejected

I cannot reproduce this. Tried multiple times in both orders (modprobe -> usb-plug-in) and the other vay around.

Marking as rejected, please re-open as soon as you see the problem again.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)