Project

General

Profile

Actions

Bug #5363

closed

all Osmocom package builds on debian unstable fail due to some asciidoc related error

Added by laforge 12 months ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
12/20/2021
Due date:
% Done:

100%

Spec Reference:

Description

https://build.opensuse.org/package/live_build_log/network:osmocom:nightly/osmo-hlr/Debian_Unstable/x86_64

[  377s] # TEXINPUTS: find LaTeX includes like \includegraphics{./common/images/sysmocom.pdf}
[  377s] # in /usr/share/osmo-gsm-manuals.
[  377s] TEXINPUTS="/usr/share/osmo-gsm-manuals" \
[  377s]     a2x -vv -L --asciidoc-opts="-f /usr/share/osmo-gsm-manuals/build/mscgen-filter.conf -f /usr/share/osmo-gsm-manuals/build/diag-filter.conf -f /usr/share/osmo-gsm-manuals/build/docinfo-releaseinfo.conf -a srcdir='/usr/src/packages/BUILD/doc/manuals' -a commondir='/usr/share/osmo-gsm-manuals/common'" --dblatex-opts="-s /usr/share/osmo-gsm-manuals/build/custom-dblatex.sty -P draft.mode=yes -P draft.watermark=0" -a docinfo -a revnumber="DRAFT " -a revdate="unknown" osmohlr-usermanual.adoc
[  378s] Traceback (most recent call last):
[  378s]   File "/usr/lib/python3.9/runpy.py", line 197, in _run_module_as_main
[  378s]     return _run_code(code, main_globals, None,
[  378s]   File "/usr/lib/python3.9/runpy.py", line 87, in _run_code
[  378s]     exec(code, run_globals)
[  378s]   File "/usr/lib/python3/dist-packages/asciidoc/a2x.py", line 1015, in <module>
[  378s]     cli()
[  378s]   File "/usr/lib/python3/dist-packages/asciidoc/a2x.py", line 1005, in cli
[  378s]     a2x.execute()
[  378s]   File "/usr/lib/python3/dist-packages/asciidoc/a2x.py", line 414, in execute
[  378s]     self.__getattribute__('to_'+self.format)()
[  378s]   File "/usr/lib/python3/dist-packages/asciidoc/a2x.py", line 714, in to_pdf
[  378s]     self.exec_dblatex()
[  378s]   File "/usr/lib/python3/dist-packages/asciidoc/a2x.py", line 729, in exec_dblatex
[  378s]     self.to_docbook()
[  378s]   File "/usr/lib/python3/dist-packages/asciidoc/a2x.py", line 684, in to_docbook
[  378s]     ' '.join(map(lambda x: "{}{}".format(x[0], " " + x[1] if x[1] else ""), options)),
[  378s]   File "/usr/lib/python3/dist-packages/asciidoc/a2x.py", line 684, in <lambda>
[  378s]     ' '.join(map(lambda x: "{}{}".format(x[0], " " + x[1] if x[1] else ""), options)),
[  378s] IndexError: tuple index out of range
[  378s] a2x: args: ['-vv', '-L', "--asciidoc-opts=-f /usr/share/osmo-gsm-manuals/build/mscgen-filter.conf -f /usr/share/osmo-gsm-manuals/build/diag-filter.conf -f /usr/share/osmo-gsm-manuals/build/docinfo-releaseinfo.conf -a srcdir='/usr/src/packages/BUILD/doc/manuals' -a commondir='/usr/share/osmo-gsm-manuals/common'", '--dblatex-opts=-s /usr/share/osmo-gsm-manuals/build/custom-dblatex.sty -P draft.mode=yes -P draft.watermark=0', '-a', 'docinfo', '-a', 'revnumber=DRAFT ', '-a', 'revdate=unknown', 'osmohlr-usermanual.adoc']
[  378s] a2x: resource files: []
[  378s] a2x: resource directories: ['/etc/asciidoc/stylesheets']
[  378s] make[4]: *** [/usr/share/osmo-gsm-manuals/build/Makefile.asciidoc.inc:70: osmohlr-usermanual.pdf] Error 1

Related issues

Related to Cellular Network Infrastructure - Bug #5287: asciidoc 10 related failures on debian unstable and testing, all builds failStalledosmith10/30/2021

Actions
Actions #1

Updated by laforge 12 months ago

this definitely should be reported upstream

Actions #2

Updated by osmith 12 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 60

This is a regression from https://github.com/asciidoc-py/asciidoc-py/commit/2b83539828452d017840d5e5e747616318aaee13, which looks like it was added to help debug #5287 reported in https://github.com/asciidoc-py/asciidoc-py/issues/223.

The fix should be trivial for this index out of range error, so I've submitted a PR and asked upstream to make a new release.

https://github.com/asciidoc-py/asciidoc-py/pull/228

Actions #3

Updated by osmith 12 months ago

  • Related to Bug #5287: asciidoc 10 related failures on debian unstable and testing, all builds fail added
Actions #4

Updated by osmith 12 months ago

  • % Done changed from 60 to 90

Fix was merged and tagged as asciidoc 10.1.1, which should make it to debian sid soon.

Reported a debian bug too:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1002066

Actions #5

Updated by osmith 12 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

No more build failures in debian sid.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)