Project

General

Profile

Actions

Bug #5289

closed

jenkins "install" tests fail regarding osmo-hnodeb / other broken packages

Added by laforge about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
11/03/2021
Due date:
% Done:

100%

Spec Reference:

Description

As can be seen in https://jenkins.osmocom.org/jenkins/job/Osmocom-repo-install-debian10/feed=nightly,label=repo-install-test/289/consoleFull , osmo-repo-install-* tests currently fail on all tested distributions with some osmo-hnodeb related error:

+ services_feed=
    osmo-bsc
    osmo-bts-virtual
    osmo-gbproxy
    osmo-gtphub
    osmo-hlr
    osmo-hnbgw
    osmo-mgw
    osmo-msc
    osmo-pcap-client
    osmo-pcu
    osmo-sgsn
    osmo-sip-connector
    osmo-stp

    osmo-pcap-server
    osmo-hnodeb

+ systemctl start osmo-bsc osmo-bts-virtual osmo-gbproxy osmo-gtphub osmo-hlr osmo-hnbgw osmo-mgw osmo-msc osmo-pcap-client osmo-pcu osmo-sgsn osmo-sip-connector osmo-stp osmo-pcap-server osmo-hnodeb
Failed to start osmo-hnodeb.service: Unit osmo-hnodeb.service not found.
+ ret=1
+ [ -n  ]
+ docker container kill debian10-repo-install-test-nightly
debian10-repo-install-test-nightly
+ exit 1
Build step 'Execute shell' marked build as failure
Sending e-mails to: jenkins-notifications@lists.osmocom.org
Finished: FAILURE

First I thought the service file was not being packaged, but it is.

The problem seems to be that the step "Installing all repository packages" doesn't actually install osmo-hnodeb. Further, it seems that the package is not building, it fails on each and every distribution and architecture:
https://build.opensuse.org/package/show/network:osmocom:nightly/osmo-hnodeb


Related issues

Related to OsmoHNodeB - Bug #5290: Not building with --enable-werror in contrib/jenkins.shResolvedosmith11/04/2021

Actions
Actions #1

Updated by laforge about 1 year ago

  • Description updated (diff)
Actions #2

Updated by osmith about 1 year ago

  • Subject changed from jenknis "install" tests fail regarding osmo-hnodeb to jenknis "install" tests fail regarding osmo-hnodeb / other broken packages
  • Status changed from New to In Progress
  • Assignee changed from pespin to osmith
  • % Done changed from 0 to 10

The problem seems to be that the step "Installing all repository packages" doesn't actually install osmo-hnodeb. Further, it seems that the package is not building, it fails on each and every distribution and architecture:

Yes, the problem was that checking if the service runs was enabled before the binary packages were available. I didn't think of that during CR of related patch, will do in the future.

I've fixed up the deb and rpm related files: https://gerrit.osmocom.org/q/topic:hnodeb-packaging

Today the package has built successfully in OBS.

However, the repo-install-* jobs will still fail because another package didn't build successfully anymore, osmo-bsc :\ Fails for all distros, e.g. here:

https://build.opensuse.org/package/live_build_log/network:osmocom:nightly/osmo-bsc/CentOS_8/aarch64

[  398s] bsc_ctrl_commands.c:756:6: error: 'mode' may be used uninitialized in this function [-Werror=maybe-uninitialized]
[  398s]   756 |  int mode;
[  398s]       |      ^~~~

I'm looking into it.

Actions #3

Updated by osmith about 1 year ago

  • Project changed from OsmoHNodeB to Cellular Network Infrastructure
  • Subject changed from jenknis "install" tests fail regarding osmo-hnodeb / other broken packages to jenkins "install" tests fail regarding osmo-hnodeb / other broken packages
Actions #4

Updated by osmith about 1 year ago

Patch for uninitialized value:
https://gerrit.osmocom.org/c/osmo-bsc/+/26094

The question is of course, why did it fail in OBS, but not in jenkins verification? Looks like there's something wrong with configure.ac, preparing a patch.

Actions #5

Updated by osmith about 1 year ago

  • Related to Bug #5290: Not building with --enable-werror in contrib/jenkins.sh added
Actions #6

Updated by osmith about 1 year ago

  • % Done changed from 10 to 40

osmith wrote in #note-4:

The question is of course, why did it fail in OBS, but not in jenkins verification? Looks like there's something wrong with configure.ac, preparing a patch.

The problem is, that configure.ac turns some warnings into errors by default. This is from before --enable-werror was added. I've submitted patches to remove this for all projects where it is present:
https://gerrit.osmocom.org/q/topic:no-werror-default

OsmoHNodeB is not built with --enable-werror, hence I didn't remove it there. Created a new issue: #5290

Actions #7

Updated by osmith about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 40 to 100

So I re-triggered the build of the nightly packages after the osmo-bsc patch was merged. The packages are built now. repo-install-test ran and finally succeeded.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)