Project

General

Profile

Actions

Bug #5287

open

asciidoc 10 related failures on debian unstable and testing, all builds fail

Added by laforge about 1 year ago. Updated about 1 year ago.

Status:
Stalled
Priority:
High
Assignee:
Target version:
-
Start date:
10/30/2021
Due date:
% Done:

70%

Spec Reference:

Description

Every of our package builds on Debian unstable started to fail last night as the apparently have gone through with the [I'm extremely sorry to hear] removal of asciidoc:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895462

The original rational given was that it's python2-only, which is no longer true since several years, see https://github.com/asciidoc-py/asciidoc-py/pull/1 - and even the Debian asciidoc I have installed on unstable (9.0.0~rc2-1) is python3.

Also, it seems still an active project, given that 10.0.1 was just released yesterday, as there were several 9.x releases last year.

So now we ahve three options:
  1. add an asciidoc package to the osmocom package repository (ideally a python3 version)
  2. transition our manuals to asciidoctor (I think I tried it once years ago and asciidoc was missing many features such as the easy integration of pktgen and mscgen)
  3. convince Debian not to drop the package

Actually, I just found https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=980930 which at the bottom hintes that a 10.0.1 has been pushed to the debian archive. Now I'm confused. Why do our build slaves?

In any case, my above analysis may be wrong. Still, we have build failures on unstable like:

[  418s] TEXINPUTS=".." \
[  418s]     a2x -vv -L --asciidoc-opts="-f ../build/mscgen-filter.conf -f ../build/diag-filter.conf -f ../build/docinfo-releaseinfo.conf -a srcdir='/usr/src/packages/BUILD/tests' -a commondir='../common'" --dblatex-opts="-s ../build/custom-dblatex.sty -P draft.mode=yes -P draft.watermark=0" -a docinfo -a revnumber="DRAFT " -a revdate="unknown" test-usermanual.adoc
[  418s] Traceback (most recent call last):
[  418s]   File "/usr/bin/a2x", line 33, in <module>
[  418s]     sys.exit(load_entry_point('asciidoc==10.0.1', 'console_scripts', 'a2x')())
[  418s]   File "/usr/bin/a2x", line 22, in importlib_load_entry_point
[  418s]     for entry_point in distribution(dist_name).entry_points
[  418s]   File "/usr/lib/python3.9/importlib/metadata.py", line 524, in distribution
[  418s]     return Distribution.from_name(distribution_name)
[  418s]   File "/usr/lib/python3.9/importlib/metadata.py", line 187, in from_name
[  418s]     raise PackageNotFoundError(name)
[  418s] importlib.metadata.PackageNotFoundError: asciidoc

Related issues

Related to Cellular Network Infrastructure - Bug #5363: all Osmocom package builds on debian unstable fail due to some asciidoc related errorResolvedosmith12/20/2021

Actions
Actions #2

Updated by pabs about 1 year ago

This issue was caused by Debian breaking the asciidoc command-line tools:

https://bugs.debian.org/998114

There are already NMUs and maintainer uploads being worked on to fix this, it should go away in the next few days.

Actions #3

Updated by osmith about 1 year ago

  • Subject changed from looks like asciidoc removed from debian unstable, all builds fail to asciidoc related failures on debian unstable, all builds fail
  • Status changed from New to In Progress
  • % Done changed from 0 to 20

pabs wrote in #note-2:

This issue was caused by Debian breaking the asciidoc command-line tools:

https://bugs.debian.org/998114

This particular issue has been fixed (as it says in the thread now). But there's still asciidoc related problems in debian unstable, which prevent osmo-gsm-manuals, and therefore all other Osmocom packages, to build successfully in debian 10.

The error looks like this:

[  312s] TEXINPUTS=".." \
[  312s]     a2x -vv -L --asciidoc-opts="-f ../build/mscgen-filter.conf -f ../build/diag-filter.conf -f ../build/docinfo-releaseinfo.conf -a srcdir='/usr/src/packages/BUILD/tests' -a commondir='../common'" --dblatex-opts="-s ../build/custom-dblatex.sty -P draft.mode=yes -P draft.watermark=0" -a docinfo -a revnumber="DRAFT " -a revdate="unknown" test-usermanual.adoc
[  312s] a2x: args: ['-vv', '-L', "--asciidoc-opts=-f ../build/mscgen-filter.conf -f ../build/diag-filter.conf -f ../build/docinfo-releaseinfo.conf -a srcdir='/usr/src/packages/BUILD/tests' -a commondir='../common'", '--dblatex-opts=-s ../build/custom-dblatex.sty -P draft.mode=yes -P draft.watermark=0', '-a', 'docinfo', '-a', 'revnumber=DRAFT ', '-a', 'revdate=unknown', 'test-usermanual.adoc']
[  312s] a2x: resource files: []
[  312s] a2x: resource directories: ['/etc/asciidoc/stylesheets']
[  312s] make[3]: *** [../build/Makefile.asciidoc.inc:70: test-usermanual.pdf] Error 1

I've traced the actual error down (as it is not printed), and created a bug report upstream:
https://github.com/asciidoc-py/asciidoc-py/issues/218

I'll disable debian unstable builds until there's a fix for this asciidoc problem. If upstream doesn't respond, we can try to to tweak the command-line to make it work or find another workaround.

Actions #4

Updated by laforge about 1 year ago

On Fri, Nov 05, 2021 at 03:40:35PM +0000, osmith wrote:

This particular issue has been fixed (as it says in the thread now). But there's still asciidoc related problems in debian unstable, which prevent osmo-gsm-manuals, and therefore all other Osmocom packages, to build successfully in debian 10.

in debian unstable (and testing?) you mean, I guess.

I've traced the actual error down (as it is not printed), and created a bug report upstream:
https://github.com/asciidoc-py/asciidoc-py/issues/218

excellent.

I think it is at least as important to report this to Debian bug-tracking.

Actions #5

Updated by osmith about 1 year ago

laforge wrote in #note-4:

On Fri, Nov 05, 2021 at 03:40:35PM +0000, osmith wrote:

This particular issue has been fixed (as it says in the thread now). But there's still asciidoc related problems in debian unstable, which prevent osmo-gsm-manuals, and therefore all other Osmocom packages, to build successfully in debian 10.

in debian unstable (and testing?) you mean, I guess.

yes, I meant in debian unstable and testing.

I've traced the actual error down (as it is not printed), and created a bug report upstream:
https://github.com/asciidoc-py/asciidoc-py/issues/218

excellent.

I think it is at least as important to report this to Debian bug-tracking.

done: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=998831

Actions #6

Updated by osmith about 1 year ago

  • Subject changed from asciidoc related failures on debian unstable, all builds fail to asciidoc 10 related failures on debian unstable and testing, all builds fail
  • Status changed from In Progress to Stalled
  • % Done changed from 20 to 30

I don't see an easy way to work around this, until it is resolved upstream. So I've disabled affected projects in debian unstable and testing, for latest and nightly. Now this doesn't generate lots of mails for known errors anymore (which obstruct important new errors that may appear).

Disabled packages

Actions #7

Updated by osmith about 1 year ago

  • Status changed from Stalled to In Progress
  • % Done changed from 30 to 60

The debian maintainer created a fix, and it works as expected:
https://github.com/asciidoc-py/asciidoc-py/pull/219

Additionally it was pointed out why the error message was hidden, so I've submitted and additional patch to fix hiding of errors (and stderr of asciidoc in general) if called through a2x:
https://github.com/asciidoc-py/asciidoc-py/pull/220

Looks like this can be resolved soon.

Actions #8

Updated by osmith about 1 year ago

  • % Done changed from 60 to 70

A new asciidoc version 10.0.2 has been released. I have re-enabled the builds for debian unstable and testing... and at least most of them are passing now.

osmo-bts is failing due to some asciidoc related error, looking into it.

Actions #9

Updated by osmith about 1 year ago

Bug report for the bug causing the build failure in osmo-bts:

It seems that includes are broken for all manual files. Only for osmo-bts it happens to cause a build failure, because there an include is done inside a [graphviz] block.

Actions #10

Updated by osmith about 1 year ago

  • Status changed from In Progress to Stalled

Building osmo-bts for debian testing and unstable disabled, until the asciidoc bug is fixed.

Actions #11

Updated by osmith 11 months ago

  • Related to Bug #5363: all Osmocom package builds on debian unstable fail due to some asciidoc related error added
Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)