Project

General

Profile

Bug #5251

VAMOS: CHANnel ACTIVation on shadow timeslots is broken

Added by fixeria 10 days ago. Updated 3 days ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Abis
Target version:
-
Start date:
10/09/2021
Due date:
% Done:

100%

Spec Reference:

Description

Starting from https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-bts-test/1432/, we see new regressions affecting all VAMOS related test cases. The problem is that osmo-bts started to NACK CHANnel ACTIVaction messages for lchans on the shadow timeslots:

(bts=0,trx=0,ts=1,shadow,pchan=TCH/F) rx chan activ but TS not in nm_state oper=ENABLED avail=OK, nack!

because they do not reflect the OML states of primary timeslots:

if (ts->mo.nm_state.operational != NM_OPSTATE_ENABLED ||
    ts->mo.nm_state.availability != NM_AVSTATE_OK) {
        LOGP(DRSL, LOGL_ERROR, "%s rx chan activ but TS not in nm_state oper=ENABLED avail=OK, nack!\n",
             gsm_ts_and_pchan_name(ts));
        return rsl_tx_chan_act_nack(lchan, RSL_ERR_RR_UNAVAIL);
}

and all members of ts->mo.nm_state are zero-initialized.

Associated revisions

Revision 3e2b7fae (diff)
Added by pespin 7 days ago

rsl: Fix all shadow TS being Chan Act NACKed

The OML NM Channel FSM state only apply to primary timeslots, hence we
need to make sure we pick the primary TS (the non-shadow one).

Due to this bug, all channels on shadow TS where NACKed because the
related state was never "Enabled Ok".

Fixes: c97a7f51e1b15d40e39df4b7d07b3c6534540186
Related: OS#5249
Related: OS#5251
Change-Id: If47e4bdd45a05ed1b5709b6e3d541f2830723e37

History

#1 Updated by pespin 10 days ago

So we need to get the primary TS then when checking that? Feel free to submit a patch then, you and neels worked on the vamos stuff and the shadow TS thing, so you probably know better.

#2 Updated by pespin 7 days ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90

Fixed by:
https://gerrit.osmocom.org/c/osmo-bts/+/25743 rsl: Fix all shadow TS being Chan Act NACKed

#3 Updated by pespin 3 days ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

This should be fixed now that the patch was merged, closing the ticket.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)