Project

General

Profile

Actions

Bug #4856

open

PCU is running but has no NS connection and does not retry.

Added by keith about 1 year ago. Updated about 1 month ago.

Status:
Feedback
Priority:
Normal
Assignee:
Target version:
-
Start date:
11/09/2020
Due date:
% Done:

0%

Spec Reference:

Description

It has been noticed that at times osmo-bts, osmo-pcu are up and running on a sysmobts, GPRS is configured but there is no NS connection to the SGSN.

What I don't have about this:

  • A method to reproduce.
  • logs leading up to failure.
  • I don't know if the NS was up and failed, or if it never came up on pcu startup.
  • osmo-bts and pcu are not current master, if fact there are some various versions installed.. (BSC is nitb)

As I am writing this, I have one case of running osmo-pcu with no connection.

pcu is not logging ANYTHING. (logging level set-all debug)
version: OsmoPCU 0.8.0.152-b90d
show stats: all counters are zero.

ntib shows all of the "states" Oper 'Enabled', Admin 'Unlocked', Avail 'OK'
as does the associated pcu osmo-bts

also, shows PCU connected:

OpenBSC# show bts 2
BTS 2 is of sysmobts type in band GSM850, has CI 2 LAC 269, BSIC 63 (NCC=7, BCC=7) and 1 TRX
Description: (null)
PCU version 0.8.0.152-b90d connected

To possibly simplify a little:
It seems to be that the PCU is in a states where it "knows" that the NS is down


OsmoPCU# show ns
Encapsulation NS-UDP-IP     Local IP: 0.0.0.0, UDP Port: 0

yet it it not trying to bring it up.
Maybe the bts did not inform the PCU of the config?

show bts statistics: also all counters at ZERO.
all rate-counters are zero.

really looks like it was never initialised.

Maybe needless to say, but worth adding - systemctl restart osmo-pcu restores service.

Actions #1

Updated by keith about 1 year ago

  • Description updated (diff)
Actions #2

Updated by lynxis about 1 year ago


OsmoPCU# show ns
Encapsulation NS-UDP-IP     Local IP: 0.0.0.0, UDP Port: 0

This looks like there wasn't any NS configuration transmitted over the PCU socket. Can you update to the latest PCU?

Actions #3

Updated by pespin 7 months ago

  • Status changed from New to Feedback

Hi keith , can you comment on whether you still see this issue? I'd say the issue was probably due to some bug in early NS2 implementation.

Actions #4

Updated by keith 7 months ago

Hi pespin I'm pretty sure it's fixed now, I haven't seen it happen with current osmo-pcu.

Actions #5

Updated by keith 7 months ago

  • Status changed from Feedback to Closed
Actions #6

Updated by keith 6 months ago

  • Status changed from Closed to In Progress

Unfortunately I have to re-open this as I am still observing it.

At least with osmocom 'latest' release.

Stack running on the BTS itself is more recent.

Actions #7

Updated by pespin about 2 months ago

  • Status changed from In Progress to Feedback

Assing daniel and lynxis as Watchers here. keith are you still have issues with current master here?

Actions #8

Updated by daniel about 1 month ago

keith wrote:

Unfortunately I have to re-open this as I am still observing it.

At least with osmocom 'latest' release.

Stack running on the BTS itself is more recent.

Could you provide the exact version?

Also is the logging behaviour still the same (nothing at all observed)?
show ns still reports no NS configured?

I'd also be interested in BSSGP logs (set to DEBUG) on a device where the issue appears.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)