Project

General

Profile

Bug #4759

master-openbsc build job fails on Debian 9

Added by laforge about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
09/18/2020
Due date:
% Done:

100%

Resolution:
Spec Reference:

Description

For a couple of consecutive days, the master-openbsc build job fails on Debian 9:

## --------------------------------- ##
## openbsc 1.3.2.4-4e53b test suite. ##
## --------------------------------- ##

Regression tests.

  1: gsm0408                                         ok
  2: subscr                                          ok
  3: bsc_subscr                                      ok
  4: db                                              FAILED (testsuite.at:28)
  5: channel                                         ok
  6: mgcp                                            ok
  7: mgcp-trans                                      skipped (testsuite.at:45)
  8: bsc-nat                                         ok
  9: smpp                                            ok
 10: bsc-nat-trie                                    ok
 11: abis                                            ok
 12: bsc                                             ok
 13: trau                                            ok
 14: mm_auth                                         ok
 15: nanobts_omlattr                                 ok

## ------------- ##
## Test results. ##
## ------------- ##

ERROR: 14 tests were run,
1 failed unexpectedly.

Details see e.g. https://jenkins.osmocom.org/jenkins/job/master-openbsc/IU=--disable-iu,MGCP=--disable-mgcp-transcoding,SM
PP=--enable-smpp,a4=default,label=osmocom-master-debian9/7918/display/redirect

I don't really know what's happening here, I don't think we changed any code. Maybe some package upgrade in Debian 9? I suggest we wither disalbe "make check" those builds, or remove debian9 as a build verification target for openbsc.git in our jenkins job?

History

#1 Updated by pespin about 1 month ago

I think it should be fixed by:
https://gerrit.osmocom.org/c/openbsc/+/20192 db_test: Disable using color in log output

It's one of the tests affected by the libosmocore coloring bug (I didn't notice this one because apparently I don't build openbsc anymore automatically within my build scripts).
Once gerrit job shows green result, I'll backport and make a new patch release.

#2 Updated by pespin about 1 month ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90

I made a patch release on top of master since we only added a few fix patches after last release.

https://gerrit.osmocom.org/c/openbsc/+/20193 Bump version: 1.3.2.4-4e53b → 1.3.3

Once merged the ticket can be closed.
REMINDER: push release tag to git origin.

#3 Updated by pespin about 1 month ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)