Project

General

Profile

Actions

Bug #4733

closed

RPM feeds don't have conflicts between nightly/latest/next

Added by laforge over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
08/27/2020
Due date:
% Done:

100%

Spec Reference:

Description

For the Debian package feeds, we have a mechanism in place that marks nightly conflicting with latest and next, and vice-versa. This is implemented in the osmo_obs_prepare_conflict shell function of common-obs.sh

This mechanism is missing from the RPM builds (it apparently was forgotten when adding RPM packages), which makes it easy to run incompatible versions of programs/libraries.

We need to replicate this for RPM based distributions like CentOS.

Actions #1

Updated by laforge over 2 years ago

  • Priority changed from Normal to Low
Actions #2

Updated by pespin almost 2 years ago

  • Assignee changed from pespin to osmith
Actions #3

Updated by osmith almost 2 years ago

  • Status changed from New to In Progress
  • Priority changed from Low to High
Actions #4

Updated by osmith almost 2 years ago

  • % Done changed from 0 to 60

I've added a the dummy package for rpm. As discussed, I've also made all packages of nightly and next depend on a specific version of the dummy package (so one can't mix packages from different dates by accident).

https://gerrit.osmocom.org/q/topic:rpm-conflict

Done is at 60% now, because I'd like to extend repo-install-test to continuously test that the conflicts work as intended. From manual testing, it appears to be working as expected.

Actions #5

Updated by osmith almost 2 years ago

  • % Done changed from 60 to 70

Previous patches are merged and rolled out. The RPM packages are built for both CentOS and openSUSE, and for the latter, rpmlint started to complain about libraries depending on specific versions of packages. This is desired in our use case (for nightly and next feeds), so I've added a patch to make the error non-fatal:

https://gerrit.osmocom.org/c/osmo-ci/+/22281

Actions #6

Updated by osmith almost 2 years ago

Actions #7

Updated by osmith almost 2 years ago

  • % Done changed from 70 to 90
Actions #8

Updated by osmith almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100
Actions #9

Updated by osmith almost 2 years ago

After succeeding yesterday, the tests failed in Jenkins tonight. I've investigated and adjusted the timer, details here:
https://gerrit.osmocom.org/c/osmo-ci/+/22354

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)