Project

General

Profile

Actions

Bug #4570

closed

TTCN3-centos-bsc-test: 159 failing tests

Added by osmith over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/30/2020
Due date:
% Done:

0%

Spec Reference:

Description

TTCN3-centos-bsc-test: 159 / 163 tests are failing.

Notably TTCN3-centos-bsc-test-sccplite only has 22 failing tests.

https://jenkins.osmocom.org/jenkins/view/TTCN3-centos/job/TTCN3-centos-bsc-test/


Related issues

Related to Cellular Network Infrastructure - Bug #4573: [centos] ttcn3-msc-test: 177 failures!Resolvedlaforge06/01/2020

Actions
Actions #1

Updated by fixeria over 2 years ago

Check out the "build" artifacts:

https://jenkins.osmocom.org/jenkins/view/TTCN3-centos/job/TTCN3-centos-bsc-test/1/artifact/logs/bsc/osmo-bsc.log

20200530074413389 DLINP <0015> input/ipa.c:287 0.0.0.0:3002 accept()ed new link from 172.18.2.100:45225
20200530074413390 DNM <0004> abis_nm.c:246 OC=RADIO-CARRIER(02) INST=(00,01,ff): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=BASEBAND-TRANSCEIVER(04) INST=(00,01,ff): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=CHANNEL(03) INST=(00,01,00): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=CHANNEL(03) INST=(00,01,01): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=CHANNEL(03) INST=(00,01,02): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=CHANNEL(03) INST=(00,01,03): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=CHANNEL(03) INST=(00,01,04): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=CHANNEL(03) INST=(00,01,05): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=CHANNEL(03) INST=(00,01,06): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=CHANNEL(03) INST=(00,01,07): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=RADIO-CARRIER(02) INST=(00,02,ff): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.
20200530074413390 DNM <0004> abis_nm.c:246 OC=BASEBAND-TRANSCEIVER(04) INST=(00,02,ff): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.

so this is something A-bis/OML related. INST=(00,01,ff) is BTS0/TRX1, so maybe configuration file is somehow wrong?

Actions #2

Updated by fixeria over 2 years ago

INST=(00,01,ff) is BTS0/TRX1, so maybe configuration file is somehow wrong?

Wait, configuration file is the same as the one used for Debian. It has a few BTS instances configured, with only one transceiver each. OML is handled by osmo-bts-omldummy, so maybe it's started in a wrong way?

Actions #3

Updated by fixeria over 2 years ago

  • Related to Bug #4573: [centos] ttcn3-msc-test: 177 failures! added
Actions #4

Updated by fixeria over 2 years ago

I think we have a similar (to #4573) problem here:

20200530074412063 DLGLOBAL <0000> telnet_interface.c:104 Available via telnet 127.0.0.1 4239
20200530074412736 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
20200530074412737 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
20200530074416847 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
20200530074417737 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
20200530074417738 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
20200530074422738 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
20200530074422738 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
20200530074426941 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
20200530074427739 DLINP <0002> stream.c:113 couldn't activate SCTP events on FD 8
Actions #5

Updated by fixeria over 2 years ago

20200530074413390 DNM <0004> abis_nm.c:246 OC=RADIO-CARRIER INST=(00,01,ff): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.

This happens when running under Debian too, and needs to be investigated separately (not related to the test case failures).

Actions #6

Updated by fixeria over 2 years ago

20200530074413390 DNM <0004> abis_nm.c:246 OC=RADIO-CARRIER INST=(00,01,ff): unknown managed object
20200530074413390 DLINP <0015> input/ipaccess.c:394 Bad signalling message, sign_link returned error: Invalid argument.

This happens when running under Debian too, and needs to be investigated separately (not related to the test case failures).

The problem is that osmo-bts-omldummy arms 8 transceivers by default, while we need just one. Please see:

https://gerrit.osmocom.org/c/osmo-bts/+/18632 osmo-bts-omldummy: make number of transceivers configurable.

Actions #7

Updated by fixeria over 2 years ago

  • Status changed from New to Resolved

I think we have a similar (to #4573) problem here:

Ticket #4573 is closed, workaround for the kernel SCTP ABI breakage has been merged.

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)