Project

General

Profile

Bug #4233

osmo-stp segfaults if IPA client with unknown unit_name attaches

Added by laforge 25 days ago. Updated 24 days ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
-
Start date:
10/18/2019
Due date:
% Done:

0%


Description

If there's no AS configured with the unit_name presented by the IPA client, OsmoSTP crashes.


Related issues

Is duplicate of OsmoSTP - Bug #4234: osmo-stp segfaults if IPA client connects to AS with routing-key != 0Resolved10/18/2019

History

#1 Updated by laforge 25 days ago

the crash happens in ipa_asp_fsm_del_route() where we OSMO_ASSERT(as). So basically we either shouldn't call ipa_asp_fsm_del_route() for which no AS hasn't been resolved yet, or we should remove the ASSERT.

#2 Updated by laforge 24 days ago

  • Is duplicate of Bug #4234: osmo-stp segfaults if IPA client connects to AS with routing-key != 0 added

#3 Updated by laforge 24 days ago

  • Status changed from New to Closed

actually, this only happened due to a non-zero routing context being configured for IPA, whcih is illegal (see #4234)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)