Project

General

Profile

Bug #3756

OsmoHLR doesn't run VTY tests

Added by osmith 9 months ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/11/2019
Due date:
% Done:

0%


Description

OsmoHLR has a tests/test_nodes.vty file, which should be used to check the VTY output with osmotestvty.py as I understand it (would be nice if somebody could confirm that).

However, osmotestvty.py does not run, as osmoappdesc.py is missing. I've quickly tried to add one (see below, copy paste from osmo-msc and adjusted). Then the test starts up, but hangs forever:

confpath /home/user/code/osmo-dev/src/osmo-hlr, workdir /home/user/code/osmo-dev/make/osmo-hlr
Running tests for specific VTY commands
test_history (__main__.TestVTY) ... Launch: ./src/osmo-hlr -c /home/user/code/osmo-dev/src/osmo-hlr/doc/examples/osmo-hlr.cfg from /home/user/code/osmo-dev/make/osmo-hlr
Opening /dev/null
Launching: PWD=/home/user/code/osmo-dev/make/osmo-hlr './src/osmo-hlr' '-c' '/home/user/code/osmo-dev/src/osmo-hlr/doc/examples/osmo-hlr.cfg'

After we got the tests running, it would make sense to run them automatically with jenkins.

osmotestvtyp.py:

app_configs = {
    "hlr": ["doc/examples/osmo-hlr.cfg"],
}

apps = [(4259, "src/osmo-hlr", "OsmoHLR", "hlr"),
        ]

vty_command = ["./src/osmo-hlr", "-c", "doc/examples/osmo-hlr.cfg"]

vty_app = apps[0] # reference apps[] entry for osmo-hlr

History

#1 Updated by osmith 9 months ago

  • Status changed from New to Rejected

This is invalid: the VTY tests do run on Jenkins and can be executed locally with:

./configure --enable-external-tests
make check

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)