Project

General

Profile

Actions

Bug #3661

closed

latest stable packages report "UNKNOWN" as version string in --version

Added by osmith about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
Start date:
10/17/2018
Due date:
% Done:

100%

Spec Reference:

Description

A jenkins job was implemented in #3555 to check for "UNKNOWN" in the --version output, and it is running through for nightly. But in "latest stable" it is failing.

Example:
https://jenkins.osmocom.org/jenkins/job/Osmocom-Debian-install-latest/43/console

Slightly off topic: right now nobody receives notifications if the -latest or -nightly job fails, should we change this (after the issue is fixed)?


Related issues

Related to Cellular Network Infrastructure - Bug #3449: network:osmocom:nightly packages have VERSION="UNKNOWN"Resolvedlaforge08/06/2018

Actions
Related to Cellular Network Infrastructure - Feature #3555: debian-repo-install-test: check if binaries report UNKNOWN as version stringResolvedosmith09/14/2018

Actions
Actions #1

Updated by osmith about 4 years ago

  • Related to Bug #3449: network:osmocom:nightly packages have VERSION="UNKNOWN" added
Actions #2

Updated by osmith about 4 years ago

  • Related to Feature #3555: debian-repo-install-test: check if binaries report UNKNOWN as version string added
Actions #3

Updated by laforge over 3 years ago

  • Priority changed from Normal to Urgent
Actions #4

Updated by osmith over 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

The job is not failing anymore since 3 months ago, and notifications are working (checked my e-mail notifications dir, it has some from this job).

Actions

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)