Project

General

Profile

Bug #2857

No automatic testing of IuPS interface

Added by laforge almost 2 years ago. Updated 3 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Iu interface
Target version:
-
Start date:
01/23/2018
Due date:
01/23/2018
% Done:

100%

Spec Reference:
Tags:

Description

Similar to the situation in OsmoMSC with IuCS, we don't have any automatic testing of the IuPS interface. Once we figured out how to properly interface RANAP from TITAN, we should be able to write test cases in TTCN-3 to automatically test our IuPS implementation.


Related issues

Related to OsmoSGSN - Bug #3224: verify ciphering after UMTS AKANew04/30/2018

Related to OsmoSGSN - Bug #4157: SGSN test regressions (likely testsuite)Resolved08/19/2019

Follows OsmoMSC - Bug #2856: No automatic testing of IuCS interfaceResolved01/22/2018

History

#1 Updated by laforge almost 2 years ago

  • Due date set to 01/23/2018
  • Start date changed from 01/22/2018 to 01/23/2018
  • Follows Bug #2856: No automatic testing of IuCS interface added

#2 Updated by laforge over 1 year ago

  • Tags set to TTCN3, 3G

#3 Updated by laforge over 1 year ago

  • Related to Bug #3224: verify ciphering after UMTS AKA added

#4 Updated by laforge 8 months ago

  • Status changed from New to In Progress
  • Assignee set to laforge
  • % Done changed from 0 to 20

I have RANAP encoding/decoding now working in TTCN-3, and I've also created a set of RANAP templates to use. Integration into the SGSN tets suite is currently ongoing.

#5 Updated by laforge 8 months ago

  • Status changed from In Progress to Stalled

The core RANAP integration, the templates etc. appear to be working. The problem is that due to bugs in the proprietary asn1 compiler we're not able to reliably transcode between BER and APER at this point. setting to stalled again.

#6 Updated by laforge 5 months ago

the transcoding issues have long been resolved, as can be seen wen looking at IuCS related tests that are already in production.

The "problem" now with IuPS is that for the Gb/BSSAP based SGSN tests we don't have the notion of a (sccp or otherwise) connection between the RAN and the SGSN. LLC messages are simply exchanged "stateless" over BSSGP. For IuPS,this needs to chang substantially, so it's much hader to have "portable" test logic that works over both a 2G and a 3G RAN.

#7 Updated by laforge 5 months ago

latest code is in laforge/iu branch of osmo-ttcn3-hacks.git

#8 Updated by pespin 4 months ago

  • Related to Bug #4157: SGSN test regressions (likely testsuite) added

#9 Updated by laforge 4 months ago

  • Category set to Iu interface
  • Status changed from Stalled to In Progress
  • Assignee changed from laforge to lynxis
  • Priority changed from Normal to High
  • % Done changed from 20 to 80

branch has meanwhile been merged AFAIR, but I don't see any Iu tests as part of SGSN_Tests.ttcn executed yet?

#10 Updated by lynxis 3 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 80 to 90

#11 Updated by lynxis 3 months ago

  • Status changed from Feedback to Closed

#12 Updated by lynxis 3 months ago

  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)