Project

General

Profile

Bug #78

osmo-bts: Infinite loop in the MS power control

Added by ipse over 3 years ago. Updated 5 months ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
osmo-bts-trx
Target version:
Start date:
Due date:
% Done:

0%

Spec Reference:

Description

Report

All the phones were offline, so i logged in and basically osmo-nitb was not getting anything from the bts there was nothing in the log on osmo-nitb, then i checked the bts and i could see only:

2014-03-19_03:32:06.46033 <000b> loops.c:142 LOST SACCH frame of trx=0 chan_nr=0x0a, so we raise MS power
2014-03-19_03:32:06.47744 <000b> loops.c:142 LOST SACCH frame of trx=0 chan_nr=0x0a, so we raise MS power
2014-03-19_03:32:06.49496 <000b> loops.c:142 LOST SACCH frame of trx=0 chan_nr=0x0a, so we raise MS power

I've restarted osmo-bts and it started to work again. For some reason got in a loop because all i could see was just that message.

Conclusion

Needs further research. The environment where this happened has lots of phones at the very edge of coverage, which may trigger various bugs in the lost frames handling.

History

#1 Updated by laforge over 3 years ago

  • Project changed from OpenBSC to OsmoBTS
  • Category changed from 235 to osmo-bts-trx

#2 Updated by laforge over 3 years ago

  • Priority changed from High to Low

#3 Updated by laforge almost 2 years ago

  • Target version set to osmo-bts-trx refresh

#4 Updated by laforge 12 months ago

  • Assignee changed from ipse to tnt

#5 Updated by tnt 5 months ago

Did anyone observe this recently ?

This issue is from 3 years ago. In the mean time all the code related to this has had major changes and the original issue also didn't include a way to reproduce.
The PA code is also "scheduled" for some overhaul anyway in another issue.

So unless someone observes this currently on a current up-to-date setup and has the ability to provide more debug traces, I'd just close this as "can't reproduce".

#6 Updated by laforge 5 months ago

  • Status changed from New to Rejected

we just reject it for now, it can be re-opened if anyone ever observes it again. If it was happening for other people at all, I suppose we would have had other reports. It's not like an infinite loop is something you would ever miss to notice...

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)