Project

General

Profile

Bug #57

sysmobts L1 is not properly closed, DSP firmware reload is required

Added by laforge over 2 years ago. Updated 7 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
osmo-bts-sysmo
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Spec Reference:

Description

We should investigate what is not properly closed and try to make it work again without requiring DSP firmware reload before osmo-bts restart


Related issues

Related to OsmoBTS - Bug #1804: osmo-bts-sysmo, osmo-bts-litecell15: L1 phy unusable after PCU disconnectsStalled2016-08-23

History

#1 Updated by laforge over 2 years ago

  • Project changed from OpenBSC to OsmoBTS
  • Category deleted (235)

#2 Updated by laforge about 2 years ago

  • Assignee changed from laforge to msuraev
  • Priority changed from Normal to Low

#3 Updated by msuraev about 2 years ago

Possibly related: starting osmobts on the device via:

LD_LIBRARY_PATH=./lib ./osmo-bts-sysmo -c osmo-bts.cfg -d PCU -r 99 -M 2>&1 | tee bts.log

leads to:

<0001> oml.c:217 OC=GPRS-CELL INST=(00,ff,ff) Tx STATE CHG REP
<0001> oml.c:256 OC=GPRS-NSVC INST=(00,00,ff) OPER STATE NULL -> Enabled
<0001> oml.c:217 OC=GPRS-NSVC INST=(00,00,ff) Tx STATE CHG REP
<0001> oml.c:547 Ignoring T2000 (150 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:547 Ignoring T2001 (180 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:547 Ignoring T2002 (180 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:547 Ignoring T2003 (1680 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:547 Ignoring T2004 (520 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:547 Ignoring T2005 (165 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:547 Ignoring T2006 (1680 ms) as sent by BSC due to suspected LAPDm bug!
<0001> oml.c:884 ADM state already was Unlocked
<0006> l1_if.c:88 Timeout waiting for SYS primitive LAYER1-RESET.conf

while starting it via "systemctl start sysmobts" works fine.

#4 Updated by laforge 10 months ago

  • Related to Bug #1804: osmo-bts-sysmo, osmo-bts-litecell15: L1 phy unusable after PCU disconnects added

#5 Updated by laforge 10 months ago

  • Category set to osmo-bts-sysmo

#6 Updated by laforge 7 months ago

  • Assignee deleted (msuraev)

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)