Project

General

Profile

Bug #4662

ttcn3-bts-test: both TC_si_sched_13_2bis_2ter_2quater and TC_si_sched_2quater are broken

Added by fixeria 4 months ago. Updated 5 days ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
07/11/2020
Due date:
% Done:

100%

Spec Reference:
Tags:

Description

Both test cases are broken since build#949 [1][2]:

Dynamic test case error: While RAW-decoding type '@GSM_SystemInformation.SystemInformation':
There is not enough bits in the buffer to decode type @GSM_RestOctets.UTRAN_GPRSMeasParamsDescOpt.presence.

I think this regression is caused by [3]. The problem is that in ttcn3-bts-test, SI2quater contains a list of UTRAN neighbor cells, that is currently not implemented in SI2quaterRestOctets. The coding of this list is quite complex (more complex than the E-ARFCN list), and would probably require us to implement some parts in C++. As a quick work around, we could avoid calling dec_SystemInformation() on SI2quater in f_l1_sample_si().

[1] https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-bts-test/949/
[2] https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-bts-test/949/artifact/logs/bts-tester/BTS_Tests.TC_si_sched_13_2bis_2ter_2quater.merged
[3] https://gerrit.osmocom.org/q/I879c37eb51ece55d79346c6bf1a4951c3f11c77e


Related issues

Related to OsmoBTS - Bug #4800: SI2quater parsing error in BTS_Tests.ttcnResolved10/11/2020

History

#1 Updated by fixeria 4 months ago

  • Status changed from New to Feedback
  • Assignee set to fixeria
  • Priority changed from Normal to High
  • % Done changed from 0 to 90

Should be fixed by this change:

https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/19212 library/GSM_SystemInformation: add dec_SystemInformationSafe()

#2 Updated by fixeria 3 months ago

  • Status changed from Feedback to Stalled
  • % Done changed from 90 to 80

Unfortunately, dec_SystemInformationSafe() did not solve the problem. The test case does not crash anymore, but still fails.

#3 Updated by fixeria 18 days ago

  • Related to Bug #4800: SI2quater parsing error in BTS_Tests.ttcn added

#4 Updated by fixeria 6 days ago

  • Status changed from Stalled to In Progress

#5 Updated by fixeria 6 days ago

  • Status changed from In Progress to Feedback
  • % Done changed from 80 to 100

Unfortunately, dec_SystemInformationSafe() did not solve the problem. The test case does not crash anymore, but still fails.

It does not crash, but still does not store the SI message in array if decoding fails. Here is a simple solution:

https://gerrit.osmocom.org/c/osmo-ttcn3-hacks/+/20883 BTS_Tests: fix both TC_si_sched[_13_2bis_2ter]_2quater

Works for me ;)

#6 Updated by fixeria 5 days ago

  • Status changed from Feedback to Resolved

Merged.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)