Project

General

Profile

Bug #4274

AS Name isn't displayed

Added by roch 14 days ago. Updated 10 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/21/2019
Due date:
% Done:

0%


Description

Hi,

It looks like AS Name isn't displayed properly even if both AS and ASPs are active.

OsmoSTP# show cs7 instance 0 asp
Effect Primary
ASP Name AS Name State Type Remote IP Addr:Rmt Port SCTP
------------ ------------ ------------- ---- ----------------------- ----------
stp2 ? ASP_ACTIVE m3ua 199.255.7.133:2919
asp-dyn-0 ? ASP_ACTIVE ipa 172.17.0.2:34856
asp-dyn-1 ? ASP_ACTIVE ipa 172.17.0.3:53584

OsmoSTP# show cs7 instance 0 as all
Routing Routing Key Cic Cic Traffic
AS Name State Context Dpc Si Opc Ssn Min Max Mode
------------ ------------ ---------- ------------- ---- ------------- --- ----- ----- -------
STP2 AS_ACTIVE 56 0.8.6 loadshare
telnahub AS_ACTIVE 0 0.0.0 loadshare

osmo-stp.cfg osmo-stp.cfg 1.36 KB roch, 11/21/2019 10:47 AM
new_asp_log.txt new_asp_log.txt 1.81 KB roch, 11/21/2019 10:49 AM

History

#1 Updated by roch 14 days ago

#2 Updated by laforge 10 days ago

Thanks for the report, this is unfortunately one of the (many) known short-comings of the original OsmoSTP implementation. The output of the "show" command was modelled after looking at Cisco ITP output.

The "problem" is that in our implementation (which is based on the M3UA/SUA RFCs) you can have ASPs that are members of multiple different AS. So there's no 1:1 relationship between them, and hence naming a single AS in the 'show asp' output is not possible.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)