Project

General

Profile

Bug #4148

Iu regressions in osmo-msc master 6 builds ago

Added by laforge 7 days ago. Updated 6 days ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
IuCS support
Target version:
-
Start date:
08/13/2019
Due date:
% Done:

100%

Resolution:

Description

Hi neels, it looks like some Iu related changes you merged 7 days ago have caused almost all Iu testcases to fail, see https://jenkins.osmocom.org/jenkins/view/TTCN3/job/ttcn3-msc-test/test_results_analyzer/

Unfortunately it also appears that the "latest" osmo-msc release was tagged after those changes, so the osmo-msc-latest tests are also affected.

It may very well be a wrong assumption in the tests (such as encryption always being enabled), but the general assumption is that developers run the test suite locally before pushing changes and resolve any regressions before submission.

So please investigate urgently and either fix master or tests or revert the related changes. Thanks!

Pau is added as a watched to this ticket so he can tag a patch release of osmo-msc after this is resolved, if needed.

History

#1 Updated by neels 7 days ago

  • Status changed from New to In Progress

#2 Updated by neels 7 days ago

  • % Done changed from 0 to 90

#3 Updated by neels 7 days ago

  • % Done changed from 90 to 60

still needs vty cmd changes

#4 Updated by neels 6 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

patch merged, the next run should fix the regressions in ttcn Iu tests since the encryption behavior is back to what it was before.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)