Project

General

Profile

Bug #4024

vty: writing the configurations results in an invalid configuration

Added by lynxis 7 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
05/25/2019
Due date:
% Done:

100%

Spec Reference:

Description

Use default configuration, after the PCU is started and conncted to the BTS,
call `write` via vty.

History

#1 Updated by pespin 3 months ago

I could not see any issues regarding this ticket.

I tried with my usual config as well as with the example config from osmo-pcu/doc/examples/osmo-pcu.cfg, then connect it to the BTS, then on the VTY I do "write" and restart osmo-pcu -> it starts correctly.

I then tried running without any config file as parameter (and no osmo-pcu.cfg present in $PWD). But then if I call "write" in VTY, I get:

# write
Can't save to configuration file, using vtysh.

#2 Updated by pespin 3 months ago

  • Status changed from New to Feedback

With this patch, I was able to start osmo-pcu with no cfg file and then save it into a file. I can also start osmo-pcu with that generated cfg file with no problem, so I think the issue is not longer present and can be closed. Leaving as feedback assigned to @lynxis.

https://gerrit.osmocom.org/c/libosmocore/+/15609 vty: Optionally Set/replace cfg file during cmd 'write file'

#3 Updated by fixeria 3 months ago

I think the issue is not longer present and can be closed. Leaving as feedback assigned to lynxis.

There was a problem with saving NS-related parameters, but it has been fixed by lynxis some time ago.

#4 Updated by pespin 3 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)