Project

General

Profile

Bug #3554

trxcon/scheduler: misaligned burst reception

Added by fixeria about 2 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
trxcon
Target version:
-
Start date:
09/14/2018
Due date:
% Done:

100%

Resolution:
Spec Reference:

Description

In some cases, as soon as a logical channel is activated, the following errors can be seen:

<0005> sched_trx.c:263 (Re)configure TDMA timeslot #2 as TCH/H+SACCH
<0005> sched_trx.c:420 Activating lchan=TCH/H(0) on ts=2
<0005> sched_trx.c:420 Activating lchan=SACCH/TH(0) on ts=2
<0006> sched_lchan_xcch.c:96 Received incomplete data frame at fn=0 (0/104) for SACCH/TH(0)
<0006> sched_lchan_xcch.c:106 Received bad data frame at fn=0 (0/104) for SACCH/TH(0)

this can happen if the burst reception would start from bid != 0.

Associated revisions

Revision 3f25909e (diff)
Added by fixeria 9 months ago

trxcon/scheduler: print completeness of the Rx burst buffers

Change-Id: Ife9f5eabc23aa2eea08b190361e10a98e890d608
Related: OS#3554

History

#1 Updated by fixeria about 2 years ago

  • Subject changed from trxcon/scheduler: misaligned xCCH reception to trxcon/scheduler: misaligned burst reception

Actually, the TCH/F implementation is also affected.

#2 Updated by ptrkrysik over 1 year ago

  • Target version deleted (Improvement of the higher layers of OsmocomBB)

#3 Updated by fixeria 9 months ago

  • Status changed from New to In Progress
  • Priority changed from Normal to High

Since [1], the layer23 applications may crash on receipt of an incomplete (but successfully decoded) xCCH block where the first burst (bid=0) is missing. The problem is that in this case trxcon (no idea about Calypso PHY) sets TDMA frame number of the corresponding L1CTL DATA.ind to 0, so the assert() in fn2ccch_block() crashes the process.

We could try to recover TDMA frame number of the first burst by subtracting 4, but this would not be correct for SACCH and PTCCH, where the bursts are being interleaved in a non-consecutive order. A smart (but of course more complicated way) would be to look-up the first frame number using the multi-frame layout tables as we already do for TCH/H.

[1] https://gerrit.osmocom.org/q/I0adab003a4060c9cef730e0432859659c51bd087

#4 Updated by fixeria 9 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 90

#5 Updated by fixeria 9 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)