Project

General

Profile

Bug #3448

RRLP: malformed position request packets

Added by fixeria about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
RRLP
Target version:
-
Start date:
08/04/2018
Due date:
% Done:

0%

Resolution:

Description

After fixing OS#3129, I've discovered that Wireshark (confirmed with the recent version) marks RRLP position
request packets as problematic because they are 'Missing Mandatory element APDU ID'.

I don't know is it the problem of Wireshark, or a problem of OsmoMSC.
Please see attached packet captures for all kinds of positioning type.

osmo_msc_rrlp.pcapng.gz osmo_msc_rrlp.pcapng.gz 436 Bytes fixeria, 08/03/2018 07:10 PM

History

#1 Updated by fixeria about 1 year ago

  • Status changed from New to Feedback
  • Priority changed from Normal to Low

I may be wrong, but according to Table 9.1.53.1/3GPP TS 04.08: "Application Information message content",
the message structure is correct. Looks like a Wireshark issue...

#2 Updated by fixeria about 1 year ago

  • Status changed from Feedback to Resolved

For sure, this is a problem of Wireshark.

The fixes have been submitted:

https://code.wireshark.org/review/28947
https://code.wireshark.org/review/28948

Closing this issue as it isn't related to OsmoMSC itself.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)