Project

General

Profile

Support #3283

compile error

Added by aligrt 3 months ago. Updated 8 days ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
05/22/2018
Due date:
% Done:

0%

Estimated time:
Spec Reference:

Description

I received following error while compling osmo-trx on rasbian, i have already build libosmocore-0-11-0 from source and installed but despite this still unable to compile osmo-trx, any one can help to resolve the issue!

configure: error: Package requirements (libosmocore >= 0.11.0) were not met:

Requested ‘libosmocore >= 0.11.0’ but version of Osmocom Core Library is UNKNOWN

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.”

I have already build following components on Rasbian from source successfully

libosmocore-0.11.0/ libosmocore-0.96.0

History

#1 Updated by alteholz 3 months ago

libosmocore.pc.in sets the current version of libosmocore

this version is obtained by ./git-version-gen in AC_INIT of configure.ac (still from libosmocore)

if that version is not set correctly, the check in osmo-trx fails

#2 Updated by pespin 2 months ago

This task looks like the typical issue in which git pull is issued in libosmocore with a new version and it is rebuilt without running make {maintainer-,dist-,}clean + autoreconf. Leaving this task open a few more days to see if author can provide feedback, otherwise I'll close it.

#3 Updated by pespin 2 months ago

  • Status changed from New to Feedback

#4 Updated by laforge 2 months ago

  • Priority changed from Urgent to Low

#5 Updated by laforge 8 days ago

  • Status changed from Feedback to Rejected

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)