Project

General

Profile

Bug #3160

/usr/local/lib/libosmocore.so: undefined reference to `clock_gettime' collect2: ld returned 1 exit status

Added by hackliu 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Osmocom Maintainers
Category:
-
Target version:
-
Start date:
04/12/2018
Due date:
% Done:

0%

Resolution:
Spec Reference:

Description

●setup script
1、install libosmocore
------------------------
  1. sudo apt-get install build-essential libtool libtalloc-dev shtool autoconf automake git-core pkg-config make gcc libpcsclite-dev
  2. git clone git://git.osmocom.org/libosmocore.git
  3. cd libosmocore/
  4. autoreconf -i
  5. ./configure
  6. make
  7. sudo make install
  8. cd ..
  9. sudo ldconfig i
    -----------------------

    2、Install Osmocom-BB
    ------------------------
  10. git clone git://git.osmocom.org/osmocom-bb.git
  11. git checkout sylvain/testing
    #nano src/target/firmware/Makefile
    CFLAGS += -DCONFIG_TX_ENABLE
  12. cd src
  13. make HOST_layer23_CONFARGS=--enable-transcriver
    ------------------------

● Error
------------------------
make1: Entering directory `/home/hackliu/osmocom-bb/src/host/osmocon'
make all-am
make2: Entering directory `/home/hackliu/osmocom-bb/src/host/osmocon'
CCLD osmocon
/usr/local/lib/libosmocore.so: undefined reference to `clock_gettime'
collect2: ld returned 1 exit status
make2: * [osmocon] Error 1
make2: Leaving directory `/home/hackliu/osmocom-bb/src/host/osmocon'
make1:
[all] Error 2
make1: Leaving directory `/home/hackliu/osmocom-bb/src/host/osmocon'
make: *
* [osmocon] Error 2
------------------------

Please help me to solve the problem, thank you.


Related issues

Has duplicate OsmocomBB - Bug #3159: /usr/local/lib/libosmocore.so: undefined reference to `clock_gettime'Closed2018-04-12

History

#1 Updated by laforge 6 months ago

  • Related to Bug #3176: osmocom debian packages are not install / upgrade tested added

#2 Updated by laforge 6 months ago

  • Related to deleted (Bug #3176: osmocom debian packages are not install / upgrade tested)

#3 Updated by zecke 6 months ago

Which Operating system is this? clock_gettime is within "libc.so" (glibc) since ages. I assume in your case it is still in librt.so?

#4 Updated by keith 6 months ago

I worked around this with LDFLAGS=-lrt when building libosmocore on an Ubuntu 12 system, which is yes... VERY old, I know.

#5 Updated by fixeria 3 months ago

  • Status changed from New to Closed

This is definitely not a problem of OsmocomBB. And seems this should be fixed by I5bebc6e01fc9d238065bc2517058f0ba85620349.

#6 Updated by fixeria 3 months ago

  • Has duplicate Bug #3159: /usr/local/lib/libosmocore.so: undefined reference to `clock_gettime' added

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)