Project

General

Profile

Bug #3159

/usr/local/lib/libosmocore.so: undefined reference to `clock_gettime'

Added by hackliu 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/12/2018
Due date:
% Done:

0%

Resolution:
Spec Reference:

Description

make2: Entering directory `/home/hackliu/osmocom-bb/src/host/osmocon'
CCLD osmocon
/usr/local/lib/libosmocore.so: undefined reference to `clock_gettime'
collect2: ld returned 1 exit status
make2: * [osmocon] Error 1
make2: Leaving directory `/home/hackliu/osmocom-bb/src/host/osmocon'
make1:
[all] Error 2
make1: Leaving directory `/home/hackliu/osmocom-bb/src/host/osmocon'
make: *
* [osmocon] Error 2


Related issues

Is duplicate of OsmocomBB - Bug #3160: /usr/local/lib/libosmocore.so: undefined reference to `clock_gettime' collect2: ld returned 1 exit statusClosed2018-04-12

History

#1 Updated by laforge 6 months ago

This looks like your libosmocore.so (which you isntalled in /usr/local/lib)
does not (or no longer?) work with your operating system. clock_gettime
is a function provided by your operating system C library. However, the error
message indicates this function is missing on your operating system.

#2 Updated by fixeria 3 months ago

  • Is duplicate of Bug #3160: /usr/local/lib/libosmocore.so: undefined reference to `clock_gettime' collect2: ld returned 1 exit status added

#3 Updated by fixeria 3 months ago

  • Status changed from New to Closed

Closing, see OS#3160 for details.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)