Project

General

Profile

Feature #3014

fix re-apply patches reverted by #3013, related: UL and DL packet assignment, and Timing Advance

Added by neels almost 2 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
02/27/2018
Due date:
% Done:

100%

Spec Reference:

Description

#3013 resulted in reverting four commits from osmo-pcu master (and I'm not sure whether those commits were important).
Look at those changes in detail, find out why they ended up breaking osmo-pcu and re-apply fixed versions.


Related issues

Related to OsmoPCU - Bug #3013: regression: GPRS fatally unresponsive since commit 'Rewrite Packet Downlink Assignment'Resolved02/27/2018

Related to OsmoPCU - Bug #1548: 11bit RACH supportStalled02/23/2016

Related to OsmoPCU - Bug #3828: UL (M)CS update errors in TBF testResolved03/07/2019

Related to OsmoPCU - Bug #3827: BSSGP counter group errors in TBF testResolved03/07/2019

Related to OsmoPCU - Bug #1524: PACCH on the wrong timeslotStalled02/22/2016

History

#1 Updated by neels almost 2 years ago

here are pointers to the patches again:

reverted:

#3013#note-2

https://gerrit.osmocom.org/#/q/status:open+project:osmo-pcu+branch:master+topic:fix_regression

=

https://gerrit.osmocom.org/6976 Revert "Use Timing Advance Index in UL assignments"
https://gerrit.osmocom.org/6977 Revert "Rewrite Packet Uplink Assignment"
https://gerrit.osmocom.org/6978 Revert "Rewrite Packet Downlink Assignment"
https://gerrit.osmocom.org/6979 Revert "Rewrite EGPRS Packet Uplink Assignment"

original patches:

commit 6298fbb7b2f3639fde994633e33ba54a64a6ef9b
Author: Max <msuraev@sysmocom.de>
Date:   Tue Jan 9 18:58:54 2018 +0100

    Use Timing Advance Index in UL assignments

    Write TAI (if available) when generating Rest Octets for UL
    Assignment. This should not affect actual PCU behavior because TAI is
    not yet supported by upper layers but we have to adjust corresponding
    tests anyway.

    Change-Id: I8b17be78a46c0bc17516b7c90f35aa4768010ae4

commit 93d947f5e8a30acc9250c124bf9d5bb6a8863526
Author: Max <msuraev@sysmocom.de>
Date:   Tue Jan 9 18:54:29 2018 +0100

    Rewrite Packet Uplink Assignment

    Use bitvec_set_*() directly without external write pointer tracking to
    simplify the code. This is part of IA Rest Octets (3GPP TS 44.018
    §10.5.2.16) which is the last part of the message so it should not
    interfere with the rest of encoding functions.

    The tests are adjusted accordingly.

    Change-Id: I44db2eeea7448ff67e688ae716487bc6dbfc96a3
    Related: OS#1526

commit 896574e92bea09ed8d39688b6fdf504e84521746
Author: Max <msuraev@sysmocom.de>
Date:   Tue Jan 9 18:45:41 2018 +0100

    Rewrite Packet Downlink Assignment

    Use bitvec_set_*() directly without external write pointer tracking to
    simplify the code. This is part of IA Rest Octets (3GPP TS 44.018
    §10.5.2.16) which is the last part of the message so it should not
    interfere with the rest of encoding functions.

    The tests are adjusted accordingly.

    Change-Id: I52ec9b07413daabba8cd5f1fba5c7b3af6a33389
    Related: OS#1526

commit 529ce885450946d85d1920fb3d1a994c3efe5849
Author: Max <msuraev@sysmocom.de>
Date:   Tue Jan 9 13:15:05 2018 +0100

    Rewrite EGPRS Packet Uplink Assignment

    Use bitvec_set_*() directly without external write pointer tracking to
    simplify the code. This is part of IA Rest Octets (3GPP TS 44.018
    §10.5.2.16) which is the last part of the message so it should not
    interfere with the rest of encoding functions.

    Reusable fragments are split into static helpers.

    Change-Id: I2139fb347b3290621bbc3f6a031f7f213d372e65
    Related: OS#1526

#2 Updated by neels almost 2 years ago

quoting laforge on irc: [a good way] "to approach this is to use the TEMS phones and look at the protocol decodes of the messages before/after the related change"

#3 Updated by neels almost 2 years ago

  • Related to Bug #3013: regression: GPRS fatally unresponsive since commit 'Rewrite Packet Downlink Assignment' added

#4 Updated by laforge almost 2 years ago

  • Assignee set to sysmocom

#5 Updated by laforge about 1 year ago

#6 Updated by msuraev 10 months ago

  • Related to Bug #1548: 11bit RACH support added

#7 Updated by msuraev 9 months ago

  • Status changed from New to In Progress
  • Assignee changed from sysmocom to msuraev
  • % Done changed from 0 to 10

The re-worked patch series is in gerrit, pending merge of MCS-related fixes.

#8 Updated by msuraev 9 months ago

  • Related to Bug #3828: UL (M)CS update errors in TBF test added

#9 Updated by msuraev 9 months ago

  • Related to Bug #3827: BSSGP counter group errors in TBF test added

#10 Updated by msuraev 9 months ago

  • % Done changed from 10 to 50

Gerrit 12956 and preceding patches should fix that.

#11 Updated by msuraev 9 months ago

  • Status changed from In Progress to Stalled
  • % Done changed from 50 to 60

The current patch series is available in https://gerrit.osmocom.org/c/osmo-pcu/+/13057/ and it's dependencies. It's tested in gprs and egprs mode (with two-phase-access option to make sure we're not affected by instabilities described in #1524) and works fine.

#12 Updated by msuraev 9 months ago

  • Related to Bug #1524: PACCH on the wrong timeslot added

#13 Updated by msuraev 9 months ago

  • Status changed from Stalled to Resolved
  • % Done changed from 60 to 100

Corresponding patches are merged into master.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)