Project

General

Profile

Bug #2983

OsmoMSC crashes on LUR

Added by fixeria over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
02/22/2018
Due date:
% Done:

0%

Resolution:

Description

The problem may be reproduced using OsmocomBB and a virtual SIM-card
(mobile configuration attached). Register a subscriber in HLR and try
to perform LUR.

LAPDm + A-bis PCAP trace is attached.
Valgrind trace of the binary is also attached.

osmo_msc_valgrind.log osmo_msc_valgrind.log 10.6 KB fixeria, 02/22/2018 09:09 AM
lur_crash.pcapng.gz lur_crash.pcapng.gz 3.35 KB fixeria, 02/22/2018 09:13 AM
mobile.cfg mobile.cfg 1.02 KB fixeria, 02/22/2018 09:14 AM

Related issues

Related to OsmoMGW - Bug #2981: make check: mgcp test failedNew02/22/2018

Related to OsmoSGSN - Bug #2982: make check: sgsn test failedClosed02/22/2018

Related to libosmocore - Bug #2986: GNU TLS fallback: segfault on gnutls_rnd()Resolved02/22/2018

History

#1 Updated by fixeria over 1 year ago

  • Related to Bug #2981: make check: mgcp test failed added

#2 Updated by fixeria over 1 year ago

  • Related to Bug #2982: make check: sgsn test failed added

#3 Updated by fixeria over 1 year ago

  • Related to Bug #2986: GNU TLS fallback: segfault on gnutls_rnd() added

#4 Updated by neels over 1 year ago

  • Status changed from New to Feedback
  • Assignee set to fixeria

Looking at the trace, it's the most normal Location Updating Request there is, and that works for me (TM):

I have tossed up a quick msc_vlr_test to send/receive exactly the messages found in your trace. Running the resulting test doesn't crash and valgrind does not show any "Invalid read of size 4". See https://git.osmocom.org/osmo-msc/commit/?h=neels/os2983&id=dbaf3bd3fed4d433cb7851f9eaea8b3e8db5e59e

Would there be anything special about using OsmocomBB? Are you sure you can reproduce the issue with everything uninstalled / compiled from scratch? (has happened to me more than once)

#5 Updated by fixeria over 1 year ago

Hi Neels. I forgot to update this change.
The root problem is described in OS#2986.

#6 Updated by fixeria over 1 year ago

  • Status changed from Feedback to Closed

This is not a problem of OsmoMSC.
See OS#2986 for details.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)