Project

General

Profile

Bug #2880

OsmoMSC never releases MO call if MNCC doesn't respond to SETUP

Added by laforge over 1 year ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
MNCC Interface
Target version:
-
Start date:
01/26/2018
Due date:
% Done:

0%

Resolution:

Description

It seems like the call is never released in case the MNCC interface never responds to a MO SETUP.

See attached trace.

Terminating the MNCC handler doesn't seem to change this either, at leaset not on the CC signalling side. The log prints:

<0004> mncc_sock.c:85 MNCC Socket has LOST connection
<0001> gsm_04_08.c:191 Clearing all currently active transactions!!!
<0007> msc_mgcp.c:1049 (subscriber:IMSI:262420000000026) invalid mgcp context, call release failed.
<0001> gsm_04_08.c:1307 (ti 08 sub IMSI:262420000000026) new state INITIATED -> NULL

however, no attempt is made to send a CC release to the MS, nor is the SCCP connection cleared.

See MSC_Tests.TC_mo_setup_and_nothing

20180126-osmomsc-mocall-setup-nothing.pcap 20180126-osmomsc-mocall-setup-nothing.pcap 2.73 KB pcap file showing the problem laforge, 01/26/2018 09:27 PM

Related issues

Related to OsmoMSC - Bug #3125: testcase for fixed "osmo-msc crashes while handling a call"New03/29/2018

History

#1 Updated by pespin over 1 year ago

  • Related to Bug #3125: testcase for fixed "osmo-msc crashes while handling a call" added

#2 Updated by neels over 1 year ago

There is a patch series coming to refactor the MSC's conn FSM to discard connections as soon as the use count reaches zero.
It is worth checking this error separately, i.e. make sure that an MNCC SETUP timeout indeed results in a use count decrement.

The FSM does not handle CC timeouts, that is still done the "old" way within our CC implementation.
Might be worth a thought to implement an actual CC FSM as well, as a child of the subscr_conn FSM, with timeouts for each state except the active call.

#3 Updated by laforge over 1 year ago

  • Assignee changed from sysmocom to neels

#4 Updated by neels about 1 year ago

(I'm not that familiar with MNCC setups, maybe someone else could investigate this one?)

#5 Updated by neels 2 months ago

(I have since then become familiar with MNCC setups and can indeed investigate this one. Once I get to it.)

#6 Updated by neels 2 months ago

  • Status changed from New to Resolved

TC_mo_setup_and_nothing passes.
I hope that means the issue is resolved.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)