Project

General

Profile

Bug #2743

JJB for gerrit-osmo-ttcn3-hacks doesn't work

Added by laforge 10 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
jenkins
Target version:
-
Start date:
12/13/2017
Due date:
% Done:

0%

Spec Reference:

Description

For some reason the gerrit-osmo-ttcn3-hacks JJB is not working as expected:

  • the https:// SCM URL is not used, but the value from the template is used (ssh://). Why?
  • the build node is not restricted to 'build2-deb9build'. Why?

So for some reason the 'scom' and 'node' parts are not overriding the defaults inhrited from the template. I have no clue why. 'jenkins-jobs test' just validates without errors, but the uploaded job is incorrect.

https://gerrit.osmocom.org/#/c/5308/2/jobs/gerrit-verifications.yml

I've manually edited it in the Jenkins UI, but that's of course a hack that will soon break.

blobb, neels, lynxis: Any ideas?

History

#1 Updated by neels 10 months ago

If config items are simply in the wrong place or not named properly, usually no error message or anything will occur. I have found a few of those so far.

node: I think only the "slave-axis" is capable of selecting nodes.

URL: I think we'd need to introduce an actual custom "git_url" config item defaulting to "git://git.osomocom.org/{repos}", and then insert it in the bottom most "scm" as "url: '{git_url}'" ... would have to trial and error to verify that this works. Just overlaying as the patch intends would be far simpler, maybe we can get a patch in at upstream (or understand why that doesn't/shouldn't work)

BTW, have once actually edited the installed jjb py code to dump each node's config tree to stdout to see what happens, which can be helpful: in /usr/lib/python2.7/dist-packages/jenkins_jobs/formatter.py, in deep_format(), I put this just before the final return: "print(pformat(ret))"

#2 Updated by zecke 10 months ago

Did you investigate neels's comment? Is this still an issue?

#3 Updated by laforge 10 months ago

On Fri, Dec 22, 2017 at 06:43:11PM +0000, zecke [REDMINE] wrote:

Did you investigate neels's comment? Is this still an issue?

I didn't find time to investigate it yet, sorry. It's not urgent, the job is
running in a manually-created version at the moment.

#4 Updated by laforge 8 months ago

  • Assignee changed from zecke to lynxis

#5 Updated by lynxis 6 months ago

I can not reproduce the issue on my machine. I've change the node to ttcn3, because only those nodes have the eclipse-titan compiler installed.

#6 Updated by lynxis 6 months ago

  • Status changed from New to Resolved

#7 Updated by lynxis 6 months ago

I've also executed the jenkins jobs builder. Maybe it's a problem with different version of jjb?

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)