Project

General

Profile

Feature #2627

Build verification against actual required minimal versions

Added by laforge 12 months ago. Updated 20 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
jenkins
Target version:
-
Start date:
11/08/2017
Due date:
% Done:

0%

Spec Reference:

Description

In autoconf (and debian/control) we state minimum versions of required upstream packages.

A job to actually install those minimum versions and check the build would be needed in order to make sure we don't break this.

So if osmo-bsc uses a function from libosmo-mgcp, and configure.ac states libosmo-mgcp >= 1.0.0, then we should build + install the 1.0.0 tag of libosmo-mgcp and attempt the osmo-bsc build.

If the build fails, the patch should IMHO not get a V+1 but remain rejected until
  1. a new version of the library has been tagged
  2. the patch is updated to update the requirement to that new version in configure.ac

I know this imposes some more obstacles in the development process, but the existing way of handling things is a constant neglect of our users and proper dependency management in distributions and elsewhere.


Related issues

Related to Cellular Network Infrastructure - Feature #2642: Jenkins job to verify PKG_CHECK_MODULES correctnessResolved2017-11-15

History

#1 Updated by neels about 1 month ago

  • Related to Feature #2642: Jenkins job to verify PKG_CHECK_MODULES correctness added

#2 Updated by neels about 1 month ago

  • Assignee changed from Osmocom Developers to osmith

Is this actually a full-on duplicate of #2642, or is there a subtle difference that evades me?

#3 Updated by laforge 20 days ago

  • Status changed from New to Rejected

neels wrote:

Is this actually a full-on duplicate of #2642, or is there a subtle difference that evades me?

Well, strictly speaking this issue talks also about
  • debian minimal version requirements (not just autoconf)
  • integrating this in our gerrit build testing

But I think we can live without those two for now, the important part has been resolved in #2642

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)