Project

General

Profile

Bug #2330

add --enable-sanitize configure flag to osmocom cellular network projects (osmo-{msc,bsc,sgsn} and dependencies)

Added by neels 6 months ago. Updated 24 days ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
Start date:
06/18/2017
Due date:
% Done:

100%

Spec Reference:

Description

Let's add the --enable-sanitize configure switch in every osmocom git repos (of interest) and include such build in the standard master HEAD as well as gerrit build jobs. We could then drop the Osmocom_Sanitize build entirely.


Related issues

Related to OsmoHNBGW - Bug #2638: segfault during IuCS connect request Resolved 11/14/2017

History

#2 Updated by msuraev 6 months ago

In libosmo-abis it was added in 8a3be282ab265a2587608e471b274dda200eae84.

#3 Updated by laforge 5 months ago

  • Assignee set to neels
  • Priority changed from Normal to Low

#4 Updated by neels 5 months ago

  • Subject changed from fix Osmocom_Sanitize build to add --enable-sanitize configure flag to osmocom cellular network projects (osmo-{msc,bsc,sgsn} and dependencies)

Actually, the fact that 'make CFLAGS+=...' breaks the build was due to an error in Makefile.am, which was using CFLAGS instead of AM_CFLAGS: fixed in https://gerrit.osmocom.org/2975

It would still be nice to have --enable-sanitize everywhere.

#5 Updated by neels 5 months ago

  • Description updated (diff)

#6 Updated by neels 28 days ago

  • Status changed from New to In Progress
  • Priority changed from Low to Urgent

I am facing segfaults in osmo-hnbgw (#2638) and started to add sanitizer options to osmo-iuh.git and osmo-msc.git. Actually, the regression tests uncover sanitizer failures right away. So adding sanitizer options now and fixing the bugs.

#7 Updated by neels 28 days ago

  • Related to Bug #2638: segfault during IuCS connect request added

#8 Updated by neels 24 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

I've added an --enable-sanitize configure flag to all cellNet git trees (merged).

https://gerrit.osmocom.org/#/q/%22--enable-sanitize%22

Found scores of new sanitizer issues using debian9 (stable), which finds more issues than deb8 did.

Also available in: Atom PDF