Project

General

Profile

Support #1923

re-enable all nightly package builds

Added by neels almost 3 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Target version:
-
Start date:
01/19/2017
Due date:
% Done:

80%

Spec Reference:

Description

since libdbi is buggy in certain versions, some of the OBS builds are disabled.
When openbsc no longer uses libdbi, re-enable all openbsc i586 builds.


Checklist

  • osmo-trx, debian 8, i586
  • openbsc, debian 8, i586
  • osmo-bts, debian 8, i586
  • openbsc, xubuntu 16.04, i586
  • osmo-bts, xubuntu 16.04, i586

Related issues

Related to Cellular Network Infrastructure - Feature #1860: Include Ubuntu 16.04 LTS in nightly buildsClosed11/28/2016

Related to Cellular Network Infrastructure - Bug #1928: nightly packages: osmo-trx fails for missing sqlite3.h and/or debian/rules errorClosed01/26/2017

Related to Cellular Network Infrastructure - Bug #2182: nightly builds for libosmo-sccp failingClosed04/25/2017

Related to OsmoNITB - Bug #1591: libdbi is buggy and slow, get rid of itClosed02/23/2016

History

#1 Updated by neels almost 3 years ago

  • Blocked by Bug #1591: libdbi is buggy and slow, get rid of it added

#2 Updated by msuraev almost 3 years ago

  • Related to Feature #1860: Include Ubuntu 16.04 LTS in nightly builds added

#3 Updated by msuraev almost 3 years ago

Another reason for disabled packages is uhd version requirements - see gerrit 1635 for details.

#4 Updated by msuraev almost 3 years ago

Note: when "hlr" part of db code is gone we should re-examine the db tests and see if failure is still there. It could as well be that reduction of code will make some parts of db tests obsolete.

#5 Updated by msuraev almost 3 years ago

  • Status changed from New to Stalled
  • % Done changed from 0 to 30

UHD version requirements have been removed in master, corresponding packages re-enabled.

#6 Updated by msuraev almost 3 years ago

  • Related to Bug #1928: nightly packages: osmo-trx fails for missing sqlite3.h and/or debian/rules error added

#7 Updated by msuraev almost 3 years ago

osmo-trx is disabled for Debian 8.0 i586 due to mysterious mmx check failure at configure.

#8 Updated by neels almost 3 years ago

Possibly related to #1869?

Not sure: I don't think that OBS moves binaries between different CPUs during the build but as both tickets seems to be related to subtle CPU features check it might as well be that fixing one will resolve (or at least help to troubleshoot the other).

#9 Updated by laforge over 2 years ago

  • Priority changed from Normal to High

#10 Updated by msuraev over 2 years ago

  • % Done changed from 30 to 40

The osmo-trx failure on i586 is caused by issue with AX_EXT in autoconf-archive in Debian Jessie. Upstream fix is tracked via https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=857754

#11 Updated by msuraev over 2 years ago

  • Related to Bug #2182: nightly builds for libosmo-sccp failing added

#12 Updated by msuraev over 2 years ago

  • % Done changed from 40 to 50

Current build failures seen to be mostly related to recent changes in libosmo-sccp (fix in gerrit 2404) and removal of obsolete packages in latest ubuntu (fixes in gerrit 2399 and 2400). While trying to reproduce problem locally I've submitted additional fix for libosmo-netif (gerrit 2401).

#13 Updated by laforge over 2 years ago

ping?

#14 Updated by msuraev over 2 years ago

  • Checklist item osmo-trx, debian 8, i586 added
  • Checklist item openbsc, debian 8, i586 added
  • Checklist item osmo-bts, debian 8, i586 added
  • Checklist item openbsc, xubuntu 16.04, i586 added
  • Checklist item osmo-bts, xubuntu 16.04, i586 added

For the currently disabled packages - see the checklist. Note: osmo-bts is only disabled because it depends on failing (due to linked libdbi issue) openbsc. It make sense to re-check one msc-split is completed as it's affecting .deb packaging heavily.

#15 Updated by msuraev over 2 years ago

  • Checklist item osmo-trx, debian 8, i586 set to Done

#16 Updated by msuraev about 2 years ago

  • % Done changed from 50 to 80

The issue is not present in https://build.opensuse.org/project/monitor/network:osmocom:nitb-split:nightly
Once they replace old nightly, we can close it.

#17 Updated by msuraev about 2 years ago

  • Checklist item osmo-bts, debian 8, i586 set to Done

#18 Updated by msuraev about 2 years ago

  • Checklist item osmo-bts, xubuntu 16.04, i586 set to Done

#19 Updated by laforge almost 2 years ago

  • Blocked by deleted (Bug #1591: libdbi is buggy and slow, get rid of it)

#20 Updated by laforge almost 2 years ago

  • Related to Bug #1591: libdbi is buggy and slow, get rid of it added

#21 Updated by laforge almost 2 years ago

  • Status changed from Stalled to Rejected
  • Assignee deleted (msuraev)

This is not needed anymore, now that OpenBSC.git only contains legacy code. We're building the full stack including osmo-bts, osmo-bsc, osmo-msc, ... on all supported distributions.

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)