Project

General

Profile

Bug #1432

simtrace: bootloader switch without function

Added by laforge almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
SIMtrace hardware
Target version:
-
Start date:
Due date:
% Done:

0%

Spec Reference:

Description

The problem is that there is an internal pull-up of ~ 15k and we use an external 10k pull-down, resulting in something like 1.5Volts at the pin, which is interpreted as 'high' even without any button press.

The internal pull-up could be disabled by software, but since we're doing a hardware re-design anyway, I suggest the following alternative:
  • remove R15 (pull-down) completely
  • attach SW2 to GND instead of 3V3

this way we have a low-active button with internal pull-up in the SAM7

History

#1 Updated by tsaitgaist over 8 years ago

  • Resolution set to fixed

fixed in KiCAD.
gerber will be rendered with v1.0

#2 Updated by laforge almost 4 years ago

  • Project changed from OsmocomBB to SIMtrace
  • Category changed from 244 to SIMtrace hardware

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 48.8 MB)